S-10 Forum banner

1 - 17 of 17 Posts

·
its lime time!
Joined
·
1,233 Posts
Discussion Starter #1
my friend at my work bought a sd 3 link, we went to put it in today and it says the lower bars shoudl be adjusted to 15.5" from center to center of bolt(accorign to the how to)... well with it screwd all the way in it was 17" so im assuming the wrong size bars were sent?

also measured the wishbone and it was 16" is that wrong as well?

another problem as well....

we went to move the front leaf perch, adn according to the instructions if we follow what it says the under the frame bolt will be rdirectly in the middle of the front part of the notch... im assuming thats not right at all, but with the template thats where it falls...

any help greatly appreciated
 

·
Baby > Home > S10
Joined
·
9,517 Posts
they REALLY need to include instructions with their stuff. relying on a many years old how to is not a good way to it, especially when the design has been changed. I would call SD and ask directly. I think it is so silly that they prefer to get asked a million questions about this over and over again instead of one of the employees taking a day and typing up a new how to, and just including it when they send a customer a 3/5link kit. just my thoughts.
 

·
Registered
Joined
·
448 Posts
they REALLY need to include instructions with their stuff. relying on a many years old how to is not a good way to it, especially when the design has been changed. I would call SD and ask directly. I think it is so silly that they prefer to get asked a million questions about this over and over again instead of one of the employees taking a day and typing up a new how to, and just including it when they send a customer a 3/5link kit. just my thoughts.
the backhalf came with instructions, a printout and a cd with pdf. :tup:
 

·
Afterhours Admin
Joined
·
27,121 Posts
wtf martin, dont you have my number? if not, you should get it haha! the howto is very old, the kit was redesigned last year, and should include a piece of paper describing the correct amount to move the hangers.

id update the howto, but i havnt had any 3links to install.
 

·
376ci LSX MCSS? Say what?
Joined
·
7,589 Posts
wtf martin, dont you have my number? if not, you should get it haha! the howto is very old, the kit was redesigned last year, and should include a piece of paper describing the correct amount to move the hangers.

id update the howto, but i havnt had any 3links to install.

you can install it on my ttruck....lol....beds off of mine anyways...
 

·
its lime time!
Joined
·
1,233 Posts
Discussion Starter #10
wtf martin, dont you have my number? if not, you should get it haha! the howto is very old, the kit was redesigned last year, and should include a piece of paper describing the correct amount to move the hangers.

id update the howto, but i havnt had any 3links to install.

that template put the hole for the brakcet right directly under the notch... ill upload a pic
 

·
its lime time!
Joined
·
1,233 Posts
Discussion Starter #11
i didnt weld any of this shit im just showing this guy what to do..

but this is what we ran into, according to that template....



with the template...

 

·
Afterhours Admin
Joined
·
27,121 Posts
ya, youre using the template wrong in that pic lol. the new template goes between the same holes, not from the front to back like the howto says.
 

·
Registered Abuser
Joined
·
9 Posts
i had the same problem with my 3 link, it was either bottoming out the driveshaft in the trans or the pinion angle was way off, i called and was told to mount the front hangers 12 inches back from the factory holes, but it still didnt work. i ended up taking it all back off just so i could drive the truck again, kinda disappointed there was no instructions except for the forum pics. im gonna try it again this winter.
 
1 - 17 of 17 Posts
Top