S-10 Forum banner
1 - 20 of 32 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have made it to the end of my journey just to be stepped on by who knows what. I put in a new harness made by a company for a 97 5.7L motor from a Silverado. They also re did the programing of the ECM from the very same vehicle to match up with the 96 S10 Blazer. I have power to all my accessories like lights and other features radio and heater for example. I replaced the instrument cluster in the blazer from another S10 that had a tach already in whereas my original did not. Now to the problem there is no power to the Coil module, coil and from what I can tell the fuel tank. Now I know that there are different types of Anti thief systems and I believe I have the Pass Lock system, I only use or have a regular key. I also know that the BCM is specific to the blazer when it was installed with the 4.3 engine.
1. Does the BCM require to be reprogramed? I understand that it controls the accessories and that could be why they appear to be working, except fuel system.​
2. Could my lock cylinder be bad since the anti-thief system is based or housed in the lock cylinder.​
3. Can that Pass lock system be reprogramed, or do I need to get a whole new ignition lock system?​
All in all after all this time I have no juice to start the vehicle. It does crank over but not spark or fuel.
Can anyone help me get over this last hurdle please.
 

· Registered
Joined
·
4,402 Posts
I put in a new harness made by a company for a 97 5.7L motor from a Silverado.
there was also no 5.7 LS engine ever installed in any truck.
maybe a 5.7 vortec, which is not an LS based platform, its a SBC.
 

· Been there Done it
Joined
·
16,795 Posts
A 97 5.7 into a 96 Blazer doesn't need any harness. Just add 2 wires from PCM to the injectors and 2 pink wires and repin 5 of the 6 in the connector to the computer and you should be good to go.
 

· Registered
Joined
·
45 Posts
A 97 5.7 into a 96 Blazer doesn't need any harness. Just add 2 wires from PCM to the injectors and 2 pink wires and repin 5 of the 6 in the connector to the computer and you should be good to go.
Sounds good but that is not the way I went I went with a harness made for the blazer and the 5.7 Any help in the issue sighted would be great. Thank you.
 

· Registered
Joined
·
45 Posts
It does not have Passlock or BCM.
Ok then what has caused the issue explained. Could it be because the ECM that came with and was married up with my blazer and the 1997 5.7 out of a Silverado is looking for a resistance signal from the ignition to activate the fuel system and spark for the ignition? Why then does everything work on the vehicle except the no current to the ignition and fuel system yet she cranks over just fine.
 

· Registered
Joined
·
4,402 Posts
Why then does everything work on the vehicle except the no current to the ignition and fuel system
even if your vehicle had VATS it would start and run for approx. 2 seconds then the pcm shuts off the fuel pump.
yet she cranks over just fine.
thats easy, the starting circuit, purple wire, has nothing to do with the engine harness.

have you scanned for any codes?
hooked up a scanner and see RPMs while you 'crank' the engine over?
there is so many things that could be going on.
do you have fuel pressure?
are your grounds good? all 3 or 4 of them?
in the end your asking us to help you figure out the custom thing you did to your vehicle.
In reality thats impossible to do.
I'd call whomever you got the harness from and ask them.
You could have a dead pcm for all you know.
engine will still crank just fine, and have no spark or fuel
 

· Been there Done it
Joined
·
16,795 Posts
Who made the custom harness? AFAIK you can't make a 97 ECM work correctly a 96. Has something to do with changes in A/C wiring and ABS systems. Folks have tried it. 95, 96, and 97 were all one year only wiring harnesses. That's why GM totally redid the trucks complete electrical in 98.
 
  • Like
Reactions: Gen210

· B4U Task Force
Joined
·
35,534 Posts
Who made the custom harness? AFAIK you can't make a 97 ECM work correctly a 96. Has something to do with changes in A/C wiring and ABS systems. Folks have tried it. 95, 96, and 97 were all one year only wiring harnesses. That's why GM totally redid the trucks complete electrical in 98.
I can confirm wiring, ecm, and ABS are different. I tried the ecm for a 97 Blazer…no joy.
 

· Been there Done it
Joined
·
16,795 Posts
I thought I remembered you had tried a 97 Ecm in a 96 and it was a no go.
Sounds to me like whoever built his harness and ECM has a bit more to learn about S10's.
It's no wonder the OP is having issues.
 

· Registered
Joined
·
45 Posts
even if your vehicle had VATS it would start and run for approx. 2 seconds then the pcm shuts off the fuel pump.
thats easy, the starting circuit, purple wire, has nothing to do with the engine harness.

have you scanned for any codes?
hooked up a scanner and see RPMs while you 'crank' the engine over?
there is so many things that could be going on.
do you have fuel pressure?
are your grounds good? all 3 or 4 of them?
in the end your asking us to help you figure out the custom thing you did to your vehicle.
In reality thats impossible to do.
I'd call whomever you got the harness from and ask them.
You could have a dead pcm for all you know.
engine will still crank just fine, and have no spark or fuel
Ok maybe I left something out. It is at a Performance shop, and they have indicated that there is no current going to the Ign Modulator and coil when key is turn to the run position. Also, there is no current going to the fuel system. The engine does crank over with no start. Brand new rebuild in vehicle. Now they indicated it could be the Pass lock Anti-theft system. Someone here indicated that there was no Anti-theft system on that year and make, yet GM says there was a Pass lock installed in all Blazers from 1996-2003. I just need to know can I either have the ECM relearn the keys or have the ECM Anti-theft system programing removed because it more than likely has the 97 Silverado programing in the ECM. The Harness and ECM are live. Lastly the dash plays a role in the Anti-Theft system, perhaps I should put the older one back in without the tach, and yes it came out of a S10 Blazer as well, I believe a 97 or 98
 

· Registered
Joined
·
4,402 Posts
there is no POWER going to the Ign Modulator, coil and fuel system.
this here is your issue. No power going to these parts is the problem. Nothing else matters at this point. With key on, these should have power.

even if your vehicle had VATS it would start and run for approx. 2 seconds then the pcm shuts off the fuel pump.
since you didn't read that part before, here it is again for you.
the PCM was prog
i think this means the pcm was programmed? What was it programmed for?
even if it had vats/passlock, it would start and run for 2 seconds and then die.
 

· Registered
Joined
·
45 Posts
this here is your issue. No power going to these parts is the problem. Nothing else matters at this point. With key on, these should have power.

since you didn't read that part before, here it is again for you.
i think this means the pcm was programmed? What was it programmed for?
even if it had vats/passlock, it would start and run for 2 seconds and then die.
I might as dumb as a bag of rocks but if when you turn the on juice goes thru system to ECM if it recognizes the key it then allows the fuel in tank pump to send fuel to engine. Well that hasn’t happened yet and there is fuel going to the injectors. Then with no spark at all from the coil please explain to me how it will even start and run for a few seconds?
 

· time to get cereal
Joined
·
7,603 Posts
You don't have passlock. You might have the older pass key that has a little pellet in it. Similar function though, no BCM.
Rectangle Font Electronic device Logo Brand
 
1 - 20 of 32 Posts
Top