S-10 Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Aloha i'm from the island of Oahu
ive never posted here before so my names Mike Nipper

2003 s10 extreme extra cab strait bed vortec v6 5 speed
'
i had my dream truck for seven months now and it always had the check engine light on and it always ran great until a month ago when i was driving home i felt it bog out at 1500 rpm and when i got to a intersection i couldnt accelerate at all i was stuck on the road , so i blipped the trottle up to 2k rpm and rode the clutch slowly to get it going. the next morning i took it to goodyear for a 130 dollar diagnostic(im retarded i know but i love my truck) low efficiency o2 after cat and low coolant temp so...

since then i've changed the o2 sensor but my cat is still bad it rattles and i got a new one that im putting in tommorow along with a flowmaster super 40 with dual 3 and a half chrome tips

i changed my fuel filter

ive put in the new thermostat, two of my bolts cracked so i had to tap a new set of holes and bolts

now my truck doesnt start it turns up to 500 rpm and dies, it idles very rough, i cant accelerate cause it bogges out, but above 3k it runs not to bad. at times its rough from idle to 1200rpm good till 1900rpm and good from2100rpm and up

i had a mechanic spray carb cleaner into the maf and it ran pretty smooth for a while but still bogged under quarter throttle

i got to work tomorrow and im pretty worried about what to do i got another mechanic looking at it after work and im stressed and feel like crap please help

i can be emailed at [email protected] or even called at 1-808-398-8451 any help is much appreciated do it for the s10 lovers
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
1. Fuel pressure should be checked.
2. NEVER spray the MAF with carb cleaner, it has it's own cleaner.

3. Install that new Catalytic Convertor
 

·
Needs money and parts
Joined
·
38 Posts
I don't want to jack your thread but I'm having a very similar problem. 99 xtreme 4.3 Bogs, coughs, spits, pops, you name it. One GM tech said my injectors were "all carboned up" would this be causing my problem or something else? Sorry nips for the thread jack, maybe we can both get our problems solved.
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
I don't want to jack your thread but I'm having a very similar problem. 99 xtreme 4.3 Bogs, coughs, spits, pops, you name it. One GM tech said my injectors were "all carboned up" would this be causing my problem or something else? Sorry nips for the thread jack, maybe we can both get our problems solved.
Poppet valves go bad and the replacement of the entire fuel spider has repaired many different ailments. Do a search...

Ignition sysytem component failure can also cause these symptoms too. Make sure all your wires, plugs cap, rotor, etc. is in good shape.
 

·
Needs money and parts
Joined
·
38 Posts
thanks ragin, i should've searched before I asked... :doh: Already placed my order for mfi spider and seal kit. I'll post back here if I have any problems.

-flug
 

·
Dump em' Out
Joined
·
5,502 Posts
if you have a low coolant temp...it also could be a bad ECT sensor. Worth replacing for the cheap cost it is. I just did mine and it isnt hard. It is located on the driver side valve cover
 

·
Needs money and parts
Joined
·
38 Posts
coolant temp seems ok, I've only had one cooling problem where the t-stat was stuck open..replaced that no problem. Then this fall, my heater was blowing cold air...so i blasted a bunch of crap out of the heater core with the garden hose...I could fry bacon with my heat now. She's getting old with 150k miles...I guess it's about time I had to fix something. =) If I have anything else, I'll make my own thread. Thanks guys!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
Shit so I had a mechanic try to charge me 25 to diagnose and 45 in gas money to come see me then install a Maf sensor for 75 bucks and I said uhhhh no you ****ing crazy or what? I went to checkers grabbed a Maf for 135 went home and slapped it in. No difference then my friend who's supposed to do my cat and exhaust said that the 300 he quoted me was only for the cat back and not installing the cat which I understand but shit I would do all that for 250 , so I thought about buying a welder and I can't get around bending pipes so cancel on that for now,

The trucks still running like shit and I get stuck on the side of the road like a loser at least once a day the the way to work and it happens at the same spot, hmmmm that's a clue, **** I'm ****in ****ed
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #10 ·
never had a tune up , yet and im thinking its a clogged cat, so im off on sunday and im hitting a muffler shop, and is it just me or are the plugs hard to reach or what ?crap i couldnt put a damn wrench on one
 

·
Forealz~!~
Joined
·
92 Posts
never had a tune up , yet and im thinking its a clogged cat, so im off on sunday and im hitting a muffler shop, and is it just me or are the plugs hard to reach or what ?crap i couldnt put a damn wrench on one
You need to unbolt part of your steering colomn to get to one of them, I don't remembeer exactly but I want to say plug 5, try searching that or changing plugs and it should pop up.

Also dud if you haven't already ordered your exhaust set up, you can get parts that don't need to be welded and do it your self, not sure what you're going for but a new cat and muf can be "bolted" in by your self, might need a sawsall to shorten a pipe or so, and getting them seperated can be a bitch, but its cheaper if fixing this things going to start hurting your pocket.
 

·
Registered
Joined
·
85 Posts
i got a cheap 3/8 wrench, took a torch to it, bent it about 60* and its perfect for the #3 plug.
 

·
Registered
Joined
·
2,608 Posts
never had a tune up , yet and im thinking its a clogged cat, so im off on sunday and im hitting a muffler shop, and is it just me or are the plugs hard to reach or what ?crap i couldnt put a damn wrench on one
I know on my ZR2 I access the plugs through the wheel wells. Much easier than from the engine bay.

If you have access to a infrared thermometer, you can measure the temp before and after the cat to determine if it is plugged.
 

·
Registered
Joined
·
2,608 Posts
You need to unbolt part of your steering colomn to get to one of them, I don't remembeer exactly but I want to say plug 5, try searching that or changing plugs and it should pop up.

Also dud if you haven't already ordered your exhaust set up, you can get parts that don't need to be welded and do it your self, not sure what you're going for but a new cat and muf can be "bolted" in by your self, might need a sawsall to shorten a pipe or so, and getting them seperated can be a bitch, but its cheaper if fixing this things going to start hurting your pocket.
Yeah he's right. If you get a direct fit cat you can bolt it on yourself as long as you have a torch for those stubborn bolts and the O2 sensor.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #15 ·
k so i took off the first cat, old cat, and stock muffler and replaced them with strait pipe, ebay cat, new o2 sensor, and a flowmaster super 40 dual out, and no change...

still have a hard time starting and rough idle , bogout at 1k and 2k rpm

i put a fuel injector cleaner with no change yet

tommorows plan wires, plugs, cap n rotor( which i need to find some help for ) id do anything for a fix...
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
Poppet valves go bad and the replacement of the entire fuel spider has repaired many different ailments. Do a search...
Just in case you did'nt see this from earlier...
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #17 ·
Problem solved!!!!!!
Checked the fuel pressure and it was 20psi
Paid 400 for a new pump and did it myself
Thank you to ragin'inferno and his recommendation life is now good again with my s10 extreme
I'll be sure to post a pic when I have time
And if anyone wants to talk about the fuel pump install let Me know
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
Problem solved!!!!!!
Checked the fuel pressure and it was 20psi
Paid 400 for a new pump and did it myself
Thank you to ragin'inferno and his recommendation life is now good again with my s10 extreme
I'll be sure to post a pic when I have time
And if anyone wants to talk about the fuel pump install let Me know
Your quite welcome Mike...I always "preach" fuel filter & fuel pressure first! :tup:
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
just an FYI a 2003 came with the MFI assembly and did not come with poppet nozzles.
Yep, your right! That's what's in my 99 Xtreme...I should have caught that!
 
1 - 20 of 23 Posts
Top