S-10 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hello,
I sure hope that someone can help me out here. Yesterday, while driving to work, my 2002 s10 blazer xtreme stalled on me while I was waiting in an intersection to make a left turn. I was not able to restart it and ended up having to push it off the road. I took the battery to autozone and they said it was bad, so I bought a new one and then installed it. My blazer still will not start, only now it seems related to it not getting fuel. Funny thing is, when I bought this blazer, (about a year ago), the alarm wasn't even working. But now after I put in a new battery, the alarm starts working. So could the alarm be shutting off the fuel so that I can't start it? Is there something I need to do to reset the security system or something? I ended up having to have it towed home and I just don't understand why it will not start. I know it's not the battery, because it's brand new, and I haven't had any problems with it now starting unitl I installed a new battery. Very strange and also very frustrating. If anyone can help me out, I will forever be in you debt. lol Peace
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #2 ·
It sounds like when you try to start a car that has no gas. It wants to start, but just won't fire up. And I never had any problem like this until I installed the new battery. Then suddenly the security system works and I can't start it up.
 

·
Registered
Joined
·
133 Posts
could be fuses . check though fuses which r fuel, coil , ing., check fuel pressure, and fuel filter.. make sure u have gas . the gas guage o these vehicle r spotty..
 
1 - 4 of 4 Posts
Top