S-10 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
240 Posts
Discussion Starter · #1 ·
so changed oil today oil smelled like gas alot also when running last night smelled bad of gas running what wood make run rich >???
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #3 ·
dono if this helps at all but starting cold seems cranks more then usual but once warmed up barely turn key and starts just can smell gas and oil smelled of mad gas today when changhed
 

·
i saw what you did there!
Joined
·
3,573 Posts
weak spark due to worn cap and rotor? bad plugs? bad wires? weak coil?

air filter dirty?

is check engine light on?

if so what codes it got?

try another map sensor?

is the TPS ok?

is IAC clean and not carboned up badly?

remove it real quick and clean it and the hole in the TB unit for it

how old is the 02 sensor?

if its very old then replac eit, i replaced mine and literally doubled my gas mileage, no joke, tons less gas wow



sounds like its way over due for some routine maintence and cleaning
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #5 ·
all sensors u said are new within 10000 miles ago no codes or cel either i am stumped on this one maybe ignition module dono
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #8 ·
wouldnt i lose coolant if was intake ??? i am leaning towards fuel pressure regulator or one the injectors now???????????
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #9 ·
well i replaced the fuel pressure regulator seems to run alot better but still smelling gas only seem to smell it when first starting what could this bee?
 
1 - 9 of 9 Posts
Top