S-10 Forum banner

1 - 5 of 5 Posts

·
1Day I'll Be Draggin'
Joined
·
15 Posts
Discussion Starter #1
My great 2.8 has been real close to the red line for about a week. problem she wont hold coolant in the bottle it flushes right out after I drive it. but still keeps what seems to be the same amount in the radiator whats the problem.
 

·
What's in a name?....
Joined
·
311 Posts
Is it possible to have your system pressure tested?

Can you see any fluid on the ground after driving it or anywhere on the engine? I would check around the water pump (may be losing it through the weep hole, indicating bad pump), near the thermostat housing, and along the overflow line. Check for breaks in the radiator near the seams around the top and down the sides.

How does the oil look? If it looks cloudy or milky, you may have a blown head gasket and even though the radiator looks to be the same level, it may be leaking fluid past the head gaskets and being replenished by what's in the overflow bottle, accounting for the loss.
 

·
1Day I'll Be Draggin'
Joined
·
15 Posts
Discussion Starter #3
Yes it always ends up all over the ground after driving. To me its like its coming out of the bottom of the radiator on the drivers side? Oil looks the same it's usally laying right behind the fluid on the ground due to a bad rear main seal HA HA.
 

·
What's in a name?....
Joined
·
311 Posts
You probably have a broken radiator, with it overheating b/c the system can never really get pressurized due to the break. I would try to get it pressure tested to verify. Sucks about the main seal.
 
1 - 5 of 5 Posts
Top