S-10 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
475 Posts
Discussion Starter #1
My ’95 S10 is giving a code 32 – EGR system. It comes on after driving for about 20-30min so I’m assuming that the valve is not opening. I haven’t noticed a difference in performance.

I cleaned it out this passed weekend with some carb cleaner, but that didn’t seem to work – the light came on as usual after driving a little bit, so I am going to buy a new one.

Does it come as a one piece unit (ie the electronic and mechanical parts because it kind of looks like the two can come apart) and how much do these usually cost?

Thanks
 

·
Insane Network Engineer
Joined
·
5,965 Posts
Take it out again (did you replace the gasket?) Not only spray it with carb cleaner, scrub it with a wire brush and push in the pintle with a pencil (eraser end) and see if it moving freely... After doing this, disconnect your negative battery for a half hour and then reconnect (resets computer) then see how things go... If you can avoid it, don't buy a new EGR...

The EGR is one solid part, can't be bought in components, it will run you about 160 if you replace it...
 

·
Registered
Joined
·
475 Posts
Discussion Starter #3
Thanks for the reply.

I replaced the gasket when I cleaned it.

I scrubbed it as best I could with an old toothbrush (srayed with carb cleaner, let it soak for 15 min, scrubbed it, sprayed with carb cleaner, let soak for 15 min, scubbed it... 3 or 4 times). But it's hard to get right inside of it.

The pintle moved up and down freely when I pushed it with the end of the toothbrush.

I didn't unplug the battery, figured it wouldn't matter because the light is off when I start up the truck and turns on after some driving and is on until I start it up again.

I think I'll try it again this weekend though because $160 is a lot for me to spend (especially if that's US$ - about $240 CAD)
 

·
Norcal
Joined
·
120 Posts
where is the EGR
 

·
Registered
Joined
·
28 Posts
hey mike where are you in canada?

you dont have bogging or stalling symptoms.

have any 1 gen parts for sale?
 

·
Registered
Joined
·
475 Posts
Discussion Starter #8
wht02x

On the TBI engine it's on the back and just below the TBI unit. (Kind of in between it and the distributor cap).

RideHigh?

I'm in Ottawa. Not a big truck scene here but it is growing, mainly a lot of kids with Hondas with "fast stickers" around here.

There's no bogging or stalling. I think the EGR is stuck closed, that why the light comes on after some driving when the computer tries to open it up. Bogging and stalling would be from it being stuck open, so that the exhaust gas is being fed back into the intake when your idling. So this would be like the EGR mod I guess, but I don't notice any performance gain and would rather have better gas mileage.

I don't have any 1st gen parts and S10 parts (at least 2nd gen) seem to be pretty scarce in the junk yards around here.
 

·
Registered
Joined
·
2 Posts
i had a big problem with my egr in my 94 s10 and it was a bitch, the only thing that i could do is take it out and clean it, which is not fun. my mechaninc said the build yup in the engine meant that buying a new one would not stop the problem. it would get clogged just as easy, and the egr valve on that truckj was about 300 dollars plus. my suggestion is to just clean it. it is easy to get out but getting it in is tough, i broke a stud off in the right ear, thank god it was not in the block, but it still cost me 500 to get it out. i cleaned mine once every 6-8 months depending on how bad the truck was running
 
1 - 9 of 9 Posts
Top