S-10 Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
Alright can someone tell me if there's has ever done this or not or if it has tell me how to fix it. Alright when im going down the road and i run it up around 5grand then let off it has this rattling noise comeing from the motor. If i rev it up sittin still it wont do it but when im going down the road it will. It has done it now for a couple of months and i cant find it. The dealership said taht it was this heat protector thing on the motor or something but i took it off and it still makes that sound. Help Please:confused:
 

·
gumby green
Joined
·
3,478 Posts
sorry i don't have an answer but i have that same sound, and would look for an answer to stop it,
 

·
Registered
Joined
·
16 Posts
I have the sme noise but it happens at high rpms just befor the transmition is going to shift the dealer told me it was the heat sheild so I took it off bit it still made the same noise havent been able to figure it out ether
 

·
littleX10
Joined
·
70 Posts
I don't know if this could be it at all but am using my best knowledge to solve your troubles. When your engine is run up to a high rpm the cylinder head gets mighty hot 600 to 700 degrees. When you suddenly lift off of accelerator the mixture gets lean on the still high rpm cylinder. Which is going to be fixed within microseconds with the engines computer to the pre ignition happening with the lean mixture. But you may hear the event happen once or twice per second as the computer tries to keep the engine happy and you happy
 

·
gumby green
Joined
·
3,478 Posts
ReddiChevyXtreme said:
I don't know if this could be it at all but am using my best knowledge to solve your troubles. When your engine is run up to a high rpm the cylinder head gets mighty hot 600 to 700 degrees. When you suddenly lift off of accelerator the mixture gets lean on the still high rpm cylinder. Which is going to be fixed within microseconds with the engines computer to the pre ignition happening with the lean mixture. But you may hear the event happen once or twice per second as the computer tries to keep the engine happy and you happy
good deal, i guess i'll have to live with it
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
I get that **** too......I figured it was something loose in the steering column.....ahhh well,

Caleb
 

·
littleX10
Joined
·
70 Posts
Coming out of the garage this morning and engine was still cold.
I gunned the throttle to run with another S10 though a V6 older one. And I heard the vibrating noise I think is being mentioned. To me it sounded like a floating valve/lifter. Definately not a pre ignition event like I first thought. Now mine is pretty new under 7k and it has me a little pissed. Why should a 4 cyl designed to rev past 6.5k have floating valves after redline for only 4 to 6 seconds? Chevrolet I am very much in need of an answer.
 

·
Registered
Joined
·
16 Posts
The noise that Im talking about is not comming from the engin it sounds like it is comming from the tranny the noise comes up in the space between the bed and the cab
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
Stupid 2.2's, they're full of crappy noises....put a system in and drown it all out so it doesn't matter anymore...thats what I'm doing!

Caleb
 

·
Deadbeat
Joined
·
1,331 Posts
dont worry guys the 4.3 is full of interesting noises too....well mine is anyway....i'll fix it when it blows up.....
 

·
gumby green
Joined
·
3,478 Posts
well i have my 2.5 i guess its the same i don't see why not
 

·
Registered
Joined
·
15 Posts
Mine makes that noise too........well mine is because of 2 reasons. 1. I need new U-joints....that makes the rattling noise when i go into reverse and before i shift and stuff.......but now its starting to rattle when i'm at idle. 2. That rattling is from a broken catalytic converter.....i dunno if that helps anyone but all that means to me is one rattling S-10 :-( .....so i just crank up my subs and enjoy some bass
 

·
Project ZO6 S-10
Joined
·
588 Posts
Just get a LOUD system and a loud exhaust, the engine is fine:rock:
 

·
Registered
Joined
·
25 Posts
My 1998 2.2l was making the same noise, and it bothered the s**t out of me...
well the other day i got a letter from chevrolet that read the following...

Dear Chevrolet Customer:

As the owner of a 1998 model year Chevrolet S-10, equipped with a 2.2L 4-cylinder engine, your satisfaction with our product is very important to us.

This letter is intended to make you aware that some 1998 model year chevrolet S-10 vehicals, equipped with a 2.2L 4-cylinder engine, may experience illumnation of the malfunction indicator lamp(MIL) and/or complaints of loss of power or rattling noise. This may be due to pieces of the inner liner of the front exhaust pipe breaking up and tumbling into the catalytic converter, which will cause failure of the catalytic converter.
 

·
Registered
Joined
·
14,881 Posts
I had the exact same problem when i bought my truck.. when you would give it gas, then let off the gas and just coast along there would be a rattling squeaking noise coming from what sounded like the tranny or exhuast under the truck. The noise could be heard extremely well when the rear window slider was open. I took the truck back to the dealership and they put if up on a lift. THe servive guy said it was just a loose heat sheild clamp... so he tightened it :rolleyes:

I soon found out on my own what the noise was when it continuned to get louder and louder. Soon i started feeling weird vibrations when i'd let off the gas. It turned out to be the rear u joint on the axle yoke that was bad, and in the month it took me to figure out that the problem was the u joint, was enough time for the joint to practly rip itself apart and loose every single roller bearing out of bearing caps.... causing the driveshaft to flop around in the yoke of the rearend of the truck. Another 100 miles and i probably would of loss the drive shaft out the back of the truck :haha:

So your hearing weird sueaks that sound like a loose heat shield.... get under there and check your driveshaft. See if you can grab it and move it around at all. Also usuing a grease gun, repack the u joints full with the zerk fittings... then take it for a drive and see iif your noise goes away. If it does... plan on buying new u joints in the future..
 

·
Registered
Joined
·
25 Posts
TB for a 98

I have a 1998 s-10 and was wondering if any of you could help me out
i was reading this other thread last talkin about TB's but i didnt recall any 98s being on there... so is it possible for me to but a TB on my truck ,and will it be worth the time and money, and where can i get one... i know alot of questions im new and trying to learn
 

·
Registered
Joined
·
276 Posts
mine does it too but i fixed the problem...there are three fuel lines that run down the passengers side of the tranny (5spd) and there inside a metal bracket on the trans all i did was cut the bracket open and put some rubber spacers in there to seperate them and the noise has been gone ever scince...dunno if it your problem but its worth a look.
 

·
Registered
Joined
·
32 Posts
I have that rattling noise too my begins to rattle at about 2000rpm then stops and starts again at 4000rpm mine is a 2001 2.2L, raven exhaust almost sounds like something is rattling inside my muffler. I can have my truck in nutral and hold the rev at 2000rpm and it makes the same rattling sound so it has to be on the exhaust and can't be the u bolt.
 
1 - 20 of 26 Posts
Top