S-10 Forum banner
1 - 8 of 8 Posts

·
Registered
1999 gmc sonoma highrider zr2
Joined
·
7 Posts
Discussion Starter · #1 ·
I have my dad's 99 GMC Sonoma high rider ZR2. It has a rebuilt motor put in rebuilt transmission, rebuilt transfer case, rebuilt front and rear gears. New electronics, new sensors new PCM and I'm trying to figure out why it turns off after an hour of driving. Everything was done in stages when the broke. Motor first then fuel pump and filters, transmission an t case. Sensors and pcm done. About to get a new radiator an distributor and flush engine og radiator an distributor. Did refresh distributor with new rotor and cap. When the truck dies it sputters than goes dead but starts right up 20 seconds later I do smell gas. Been chasing this problem for 2 years now replacing parts with new ones. Any ideas?
 

·
Registered
Joined
·
100 Posts
Sounds like an ignition problem to me. Bad coil. Lose connectors on the coil. Bad icm. When I bought my truck it had a mysterious shut down issue, after chasing for a while I figured out that it was the connectors on the coil. You may want to idle the truck and wiggle the connecters on the different ignition components to see if you can get it to die.
 

·
Been there Done it
Joined
·
12,767 Posts
On a 99 the redundant oil pressure switch is no longer used. It is a single wire directly to the gauge only. So it would have nothing to do with engine cutting out.
One possibility would be a bad CKP, but once they start acting up they usually quit completely in a short time. Not 2 years. I've seen them hang on for a couple months.
 

·
Registered
1999 gmc sonoma highrider zr2
Joined
·
7 Posts
Discussion Starter · #5 ·
I replaced ckp 3 times. Checking the distributor and ignition module. This weekend to see if makes an difference.
 

·
Registered
1999 gmc sonoma highrider zr2
Joined
·
7 Posts
Discussion Starter · #6 ·
Now I have a blueish white smoke coming out of the exhaust and smells like gas and a misfire but computer not picking it up.
 

·
Registered
1999 gmc sonoma highrider zr2
Joined
·
7 Posts
Discussion Starter · #7 ·
I have done a lot of testing and checking out stuff for probable causes. New plugs wires maf. I did remove all my ac system out of it but would that cause it to dump fuel and misfire with now codes?
 

·
time to get cereal
Joined
·
5,806 Posts
Do you have the factory service manual? Since you replaced so many parts, you might want to read through the procedures and troublehshooting charts to make sure everything was done correctly. You can find them on ebay pretty easily if you don't have them already.
 
1 - 8 of 8 Posts
Top