S-10 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
i finally got my 305 700r4 in my 88 jimmy. i noticed that some of you have the radiator setting in the forward spot. did you have to cut the bottom of the radiator support out to make it fit? what radiators are yall using. thanks in advance.
 

·
Registered
Joined
·
205 Posts
If you are using the Be Cool, Griffin, or Vette radiator, yes, you have to cut out the underside of the upper radiator support. Not a real big deal and it gives you a lot more room.

Ryan
 

·
footbraker
Joined
·
1,236 Posts
I'm using a Be Cool rad. and didnt have to cut anything, pretty much a drop in. Prolly more than one style of rad.
 

·
Registered
Joined
·
42 Posts
i got my 3 core radiator out of like a early 90s camaro with lt1 or somethin and i cut our bottom radiator support to give about a half inch drop or lil more. so my radiator kinda sits in slanted.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
thanks fellas. i haven't had much time to work on my jimmy, but maybe i can finish it soon.
 

·
RFG Customs
Joined
·
758 Posts
I use a factory s-10 4.3 rad.works great in the stock location.
 

·
Registered
Joined
·
181 Posts
I am running a 4.3 radiator. With the flex fan, it didn't really work too good in traffic. I never overheated though. I will be installing a dual factory electric fan that I picked up at a boneyard. They will be HUGE to put in there, but they should work. I am runing a 160 thermostat.
 

·
Registered
Joined
·
31 Posts
I am running the Vette rad. Its works ok. I may be wrong but you can have one custom bult from griffin to fit the exact measurement of it in the forward position and just cut aplace for the radiator cap. I may be mistake but read some where that a guy did that but not sure how it worked out. Any one done this?
 
1 - 9 of 9 Posts
Top