S-10 Forum banner
1 - 4 of 4 Posts

·
ESSTEN Concepts Founder
Joined
·
465 Posts
Discussion Starter · #1 ·
hey guys,
I'm needing some help here BAD. The truck's in the shop. Well, it has been for 2 weeks now. The first problem was the tranny. It had to be totally "rebuilt" according to the tranny people. Now after $1700 later, the truck won't start. There's no spark at the distributor. We replaced the coil, which the other one somehow found its' way to the exhaust manifold and melted the corner of. Then we checked the obvious stuff like wires plug-ins etc.. around that area. Then today we changed the spark control module.. I think that's the name of it. It's flat and C shaped and has 2 plug-ins. Well that's not it either. The only thing left that we can think of is the module that's mounted to the shaft of the distributor. Has anyone had this problem before and how did you fix it?? I HAVE to get this done before the weekend. BTW it's an 87 S10, 2.8 TBI

thanx in advance for any help..

later
Mike
 

·
ESSTEN Concepts Founder
Joined
·
465 Posts
Discussion Starter · #6 ·
Thanx for the info. I'll be sure to check all that this afternoon. As for the ECM fuse or any other fuses, I made sure to check those out yesterday and All's good. I pulled the cap off and didn't notice any burn marks. I'll take the button off today and check. Dayum this sucks! If it's not one thing, it's another huh?!?! lol Crossing fingers...

later
Mike
 

·
ESSTEN Concepts Founder
Joined
·
465 Posts
Discussion Starter · #7 ·
Hey,
I checked the fusebox for any fuse that would be associated with that and all's well. Hopefully I'll get it all str8 today though

later
Mike
 

·
ESSTEN Concepts Founder
Joined
·
465 Posts
Discussion Starter · #8 ·
UPDATE...:thumbup: The mini's running FINALLY. As it turns out it was the Pickup Coil on the distributor. One of the mechanics had a spare distributor that he basically sold me for $50 complete so I got to replace the pickup coil plus the other spark control module. It was a ***** to get her timed up but it's all good now. I'm looking into getting a blazer soon now. That way I'll have another ride to drive/work on and vice versa. I may have found a 91ish 4dr. 2wd blazer for about $2500. Now I hope I can get it..lol

thanx for the help.
Mike
FINALLY rolling LOW once again.
 
1 - 4 of 4 Posts
Top