S-10 Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1 (Edited)
Well here are some picks of my 1985 s10. I hope this works. Also can anyone tell me what fans to use to keep this thing cool at a stand still. cools fine down the road but get hot at stop lights. what elect. fans should i get that will work i have a 4core rad. also.
 

Attachments

·
gumby green
Joined
·
3,478 Posts
sweet ride, i like the color, i've heard of black magic fans and i heard they work pretty well, so look into them on summit or jegs. i like it alot!
 

·
NTBSSHEVN
Joined
·
9,248 Posts
Looks good
 

·
Registered
Joined
·
20 Posts
Try This

Try at I did. I knew that the stock fan and radiator wasn't gonna cool this Small-block of mine so I first installed a 14" electric fan to the stock S10s radiator. Worked OK but it still was a bt HOT. Which I knew ws gonna hppen. I just installed the fan to see how much it would cool the engine until I ordered the BE COOL (larger) aluminum radiator from JEGS. I ordered the radiator hooked up the fan intstalled and it cools the motor greatly. My motor was "hot rodded" so I knew it would run hot but hey Iwas so impatiet to get this thig on the road. But ya bruh try out a electric fan and see how it works out 4 ya.
 

·
General L33
Joined
·
1,947 Posts
all you need to do is put a shroud on the fan you have on there. it's pulling air from everywhere but the radiator, get a shroud on there, make sure the fan blade is about 1"inside the shroud and you shouldn't have any problems.

good luck!

edit: you can also get a rag w/ some 409, greased lightning, etc and run them down the spark plug wires to clean them up to look new. ;)
 

·
Registered
Joined
·
31 Posts
Discussion Starter #13
Hotwire- thanks for noticing the plug wires i have new ones on the way. Also I want a elect. fan but dont know what one to go with.

everyone else thanks
 

·
Blue '85
Joined
·
10 Posts
Like the color of your ride...is that stock? A word of caution about the black magic fan - I put one on my aunt's '97 ZQ8 Sonoma,it worked for about a year til the built-in temp sensing switch failed. Same thing with a Bronco I used to work on and that guy's wife kept driving it until it smoked the engine. Im running a fan and clutch right now but will probably switch to a stock 3.8 Taurus or LS1 Camaro set-up soon.Heard good things about both.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #17
v8blase- the rad came with the truck i dont know what kind it is i just know its a 4core rad. the hoes i got from adv. auto parts my friend works there we just tried and tried till we found one that was close then it was a little long so we cut it some works great. thanks

jeff
 

·
Blue '85
Joined
·
10 Posts
An upper hose that works with the vette radiator in the forward position is for a late '70s firebird with the 403 Olds engine - not the hot 400 pontiac motor (both were sold in 6.6 Trans Ams). You need a t-stat housing for a small block chevy van that points to the drivers side also, then a reducer on the radiator end since the hose is larger than the neck on the radiator.
 

·
General L33
Joined
·
1,947 Posts
get a set of dual fans from a wrecked camaro/firebird/corvette/impala/caprice/roadmaster/etc.

they pull tons of air, don't pull that much current, and work really well. I have a set on my 97 s-10 and feel they pull more air than the flexalite 210s. I also used a wiring diagram from the camaros where the fans will be in series when i first crank the truck, so they are running 6 volts apiece. then when i kick on a/c or the thermo switches on, the fans kick over to parallel and run full speed. it works really well.
 
1 - 20 of 24 Posts
Top