S-10 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6,908 Posts
Discussion Starter #1
Got my 6.0L Cherokee swap ready for the track. Sorry, not an S10, but who wants to take a guess at what I run!
Planning on taking it to the track tomorrow, Friday.


2wd Cherokee, the little one. 2wd. I'd guess it weighs about 3500 with me.
The 6.0L is an LQ4, stock except for an LS1 intake and the shorty headers. 2-1/2" Y-pipe into a cheap 3" muffler and 3" tailpipe.
CAI, yes it really IS cold air.
4.10 rear gears with limited slip.
4L80e
235/55-17 tires.
Electric rad fan. No cooling issues at all with this setup.

I've done nothing tune wise, just played with the shift settings.

It does not hook in 1st or 2nd gear on the street. I have to pedal it in 1st & 2nd to keep it straight.
It runs clean and strong right now.

I've run several of my trucks at this track so I know what I'm doing. I'm confident that I'll do about as good with this setup as anyone can.

The track is a good track, certified for Top Fuel. The temps should be around 95º tomorrow.

There, I've been as honest and upfront as I can be. Your guess is as good as mine.

Post your guesses below. I'll update tomorrow evening as the racing progresses.
 

·
Registered
Joined
·
6,908 Posts
Discussion Starter #6
Hi guys

Sorry to put a damper on your enthusiasm but the beast is not ready for the track. The HP Tuners learning curve is getting the best of me. I thought I'd have it close enough to be safe but not so. This weekend will be a crash course on how to tune your 6.0L Cherokee.

But don't stop guessing, I'm going to beat this thing.
 

·
Registered
Joined
·
6,908 Posts
Discussion Starter #8
Looking good for racing tomorrow, Friday.

Forecast is for hot weather, around 95º
Truck is running good.
I'll post as the evening progresses. Pacific Time.
 

·
Registered
Joined
·
6,908 Posts
Discussion Starter #11
Well I had 5 runs. It was hot! Traction off the line was better than I had thought, but the heat sucked the power down.
Being new to HP Tuners I had spent the last 2 weeks in learning mode while also debugging the new swap and everything that goes with it.
The last couple of days were crazy, but I'm glad I got to the track today.

As the night cooled the power got better but the traction got worse!
My first 2 runs were 13.9 @ 99 mph, my last 3 runs were 14.1 @ 98 mph.

I've got to get the truck to shift sooner. The HP peak is around 5200-5400 RPM. The 1-2 shift happens at 5800 RPM and the 2-3 shift happens at 6100 RPM. I can feel the power drop off and it won't shift.
Also beyond 5200 RPM the wideband shows my AFR to be 11.0 and as low as 10.2. Way too rich to make power. I had no time to tune WOT, and it's not practical to do WOT tuning on the street!
I knew it would be rich and I was watching the wideband, so I knew I was at least safe to run it.

As it was I had only just got the basic fuel table tuned hours before the race. Then I still had lots of little bits to take care of.
The camera is one thing I didn't have time to preview and trusted that the previous camera results would be enough to go on. I've got a wicked buzzing, maybe vibration is causing audio problems. And, I set the exposure too high, but at least I can see inside the car!

So first on the list is shifting, then deal with the lack of traction, bigger tires needed.

Not sure when the next time I'll be able to take it to the track, I need some time away from this thing.

Not much of a video, but it is what it is.
 

·
Registered
Joined
·
6,908 Posts
Discussion Starter #13
I had predicted mid 13's myself. I think it's about all I will get out of it with bigger stickier tires and polishing my tune.

Maybe over the winter a cam and intake may find its way under the hood.
 
1 - 14 of 14 Posts
Top