S-10 Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
406 Posts
Discussion Starter · #1 ·
When I took my parking brake cables off my '03 Extended Cab 3 years ago I thought "there's no way I could have a problem putting these back on..." so I didn't take pictures. Now for some reason things aren't lining up right and I feel like an idiot cause it's got to be something stupid. Could someone take a couple of good shots of the brake cables running along the D side frame rail, in particular the adjuster and through the rear hanger? Also, anyone know of a good source for the spring that goes between the adjuster and the bracket. It kind of looks like a big drum brake return spring and mine looks pretty beat. I'd like to find another before this one lets loose.

Thanks
 

· Registered
Joined
·
406 Posts
Discussion Starter · #5 ·
manbearpig is right. I'm looking for a picture of where the single cable that comes out of the cab goes into the splitter/tension adjuster mess (terrible design imho) and goes back to the D side rear wheel and around the gas tank to the L side. The spring I'm referencing attaches to the tension adjuster and pulls is back toward the rear of the truck. I've got discs on the rear of my truck.
 

· time to get cereal
Joined
·
7,603 Posts
I can get you pictures in a bit. My main truck has a handbrake so the cables aren't stock, I'll have to get into my garage and take pictures of my other one.
 

· Registered
Joined
·
406 Posts
Discussion Starter · #7 ·
I greatly appreciate any help you can give me. Hopefully Al Gore didn't get you before got some pics.
 

· Registered
Joined
·
30 Posts
Sorry I forgot. Thought someone else might chime in. This is my '95.

View attachment 360109
Having this issue as well. This helps me out. Hoping goes as planned on this! Been a nightmare so far. Axle shafts, rear wheel bearings, wheel seals, new rear brakes and hardware, new rear brake lines, new wheel cylinders, and new brake cables. I forgot how much I hate drum brakes…..
 
1 - 9 of 9 Posts
Top