S-10 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter #1
It was running rough so I put new wires in, dz cap, rotor, pcv, fuel and air filter. Plugs weren't that old so I left them. Looks like all the vacumn hoses are connected. It will not maintain an idle speed. Any suggestions? I checked that all plug wires were connected correctly on the plugs and dz cap. Thanks
 

·
Registered
Joined
·
855 Posts
I wouldn't know where to tell you to start on that 2se with all that attached to it..

Sorry.
 

·
Registered
Joined
·
256 Posts
Discussion Starter #3
Come on! Ya gunna let 300 feet of tubing scare ya?
 

·
Registered
Joined
·
855 Posts
Yes......yes I am......

LOL...that is what my truck started out with. What a pain in the ass.....

Oh, I have some spare parts for the 2se. I don't remember what exactly, but I no longer need them.

I'll let you know what they are when I find them if you are interested.
 

·
Registered
Joined
·
855 Posts
I found the box, a couple of electric choke elements and 3 brand new choke pull off's.

Sorry, thought I had more parts than that.

When was the last time that carb was rebuilt?
 

·
overthinker extraordinar
Joined
·
650 Posts
Check the timing? If so then I would start looking for vacuum leaks. If you haven't replaced ALL of the vacuum tubing, do so. One piece at a time. It will take a little time, but it will also make a huge difference on the running. Turn up the idle speed a little if you need on the carb. If you have done the tubing and tune up, and it still runs rough, then I would check further. How many miles on the motor?
 

·
Registered
Joined
·
855 Posts
When I had the 2se carb on my engine, it gave me fits because charcoal from the canister got sucked up into it. Had to replace the canister as the mesh filter in it had disintegrated, thus allowing the carb to suck up some charcoal.
 

·
Registered
Joined
·
256 Posts
Discussion Starter #8
I found the box, a couple of electric choke elements and 3 brand new choke pull off's.

Sorry, thought I had more parts than that.

When was the last time that carb was rebuilt?
I did the carb in Jan 2004 at 82k miles. I put a new float in along with a secondary pull off. It now has 95k
 

·
Registered
Joined
·
256 Posts
Discussion Starter #9
Check the timing? If so then I would start looking for vacuum leaks. If you haven't replaced ALL of the vacuum tubing, do so. One piece at a time. It will take a little time, but it will also make a huge difference on the running. Turn up the idle speed a little if you need on the carb. If you have done the tubing and tune up, and it still runs rough, then I would check further. How many miles on the motor?
I'll check the timing tomorrow. Motor has 95k. I was under the impression there is no curb idle adjustment. Are you saying there is one. I know there is a fast idle adjustment.
 

·
Registered
Joined
·
256 Posts
Discussion Starter #10
When I had the 2se carb on my engine, it gave me fits because charcoal from the canister got sucked up into it. Had to replace the canister as the mesh filter in it had disintegrated, thus allowing the carb to suck up some charcoal.
Will check tomorrow. Thanks.
 

·
overthinker extraordinar
Joined
·
650 Posts
I'll check the timing tomorrow. Motor has 95k. I was under the impression there is no curb idle adjustment. Are you saying there is one. I know there is a fast idle adjustment.
I am not well versed in the q-jet 2bbl on these, other than I hate them. I ASSUMED there was one. And if so then a slight adjustment might help. I know there is no idle fuel mixture adjustment(at least with out removing the plug).

I have an 85 with the 2.8l To me it sounds like vacuum problems. Do you have emissions tests that you need to worry about where you live? If not I would look seriously at removing the "E" stuff if possible.
 

·
Registered
Joined
·
855 Posts
Took me a while to find it, but I had to buy the service manual for the Varajet 2SE carburetor.

I think it was 15 bucks or something like that.

It's 16meg and I can't attach it, but send me a pm with your e-mail addy and I'll email it too you in two parts later.

Never mind that, here you go: (mine has 27 pages, this one has 25, I don't know what to pages are missing)

http://c777913.r13.cf2.rackcdn.com/varajet_service_manual.pdf
 

·
Registered
Joined
·
256 Posts
Discussion Starter #13
Thanks. I have one that I printed out 5-6 yrs. ago. Guess I should read about idle adjustments.
 

·
Registered
Joined
·
256 Posts
Discussion Starter #14
It now runs great.
I replaced 6' of vacumn hoses - not all, I ran out of hose and have to get more. The carb adjusting screw was way in too much, only 1 turn from all in. I think when they did emissions here the garage cranked it in so it would pass. Now I have it 5 turns out. Timing was a bit retarded. I have it now 13-14 degrees BTDC in park - it says to adust in DRIVE but I'm one person and that is difficult. I messed with the auto choke and fast idle cam screw. I replaced my new Autolite "Professional Series " 7mm coil wire with a new Jegs 8mm wire that I had. That's it.
 

·
Boozebag
Joined
·
8,995 Posts
Most of the time (if you have not removed the carb or changed anything else) the idle mixture - as you found out - is the problem. Backing out the mix screw at the base of the carb usually cures the issue. (unless you have a vacuum leak)
These carbs have a plug (from the factory) over the screw to keep anyone from changing the idle mixture. At least yours was removed by someone.

Always good to hear a success story. :)
 

·
Registered
Joined
·
256 Posts
Discussion Starter #16
...
 

·
Registered
Joined
·
256 Posts
Discussion Starter #17
I rebuilt the carb 11 yrs ago and drilled out the plug
 

·
Boozebag
Joined
·
8,995 Posts
^^^ Bonus.

Long time owner! :cool:
 

·
Awww..you ain't got shit!
Joined
·
3,268 Posts
I've had mine 18 years!
 
1 - 19 of 19 Posts
About this Discussion
18 Replies
5 Participants
jimmykicker
S-10 Forum
S10forum is the community to discuss the S-Series, Chevrolet Colorado and GMC Canyon. Join to discuss rebuilds, modifications, tech articles and more!
Full Forum Listing
Top