S-10 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hi Guys,
I'm from Canada so your guages read differently than ours but hopefully someone has had the same issue.

I have a 01 LS ext cab w/ 2.2L . On a cold start the oil pressure gauge reads 400+ kpa (75%) I drive about 50 mins to work and by the time get there and slow down for city traffic, the oil pressure guage drops to the 125kpa line which is just above the red zone. It will go up and down with acceleration and braking. It doesn't sputter or lad and so I don't know if the motor is hurting or not. It idles fine even though is sitting at the red zone line.

Has anyone had this issue and what did you do? should I be concerned? I have had some fluctuating fuel guage issues as well so I'm wondering if its the dash and I shhould install some pod gauges on the pillar to know wtf is going on with it.

All comments are appreciated

Mark
 

·
Registered
Joined
·
181 Posts
at first i thought it might have been your oil sending unit they crap out a lot on these trucks. but since your other gauges are going funky id check for wiring problems.
 

·
i saw what you did there!
Joined
·
3,573 Posts
an actual working and accurate oil reading in the dash is pretty rare and uncommon, especially the older the truck, most of them i come across around here have a non functioning oil guage, or is very innacurate

replace these parts, especialyl sending unit/switch

are failing, is common
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
an actual working and accurate oil reading in the dash is pretty rare and uncommon, especially the older the truck, most of them i come across around here have a non functioning oil guage, or is very innacurate

replace these parts, especialyl sending unit/switch

are failing, is common
ok thanks. Where is the sending unit located and the switch located? I tried looking online but I could find much info.

Thanks
 

·
Registered
Joined
·
233 Posts
oil sending unit is above passanger tire you have to look threw the wheel well to see it its in there i cant even get my oil gauge to work right ive changed it out 3 times (advance auto parts) and im about to buy one from napa and try it they dont even work have the time chevy rushed a bunch of parts for this year...u need like a 22 or 23 inch socket with like 4 long extentions to get to it
 
1 - 5 of 5 Posts
Top