S-10 Forum banner

1 - 7 of 7 Posts

·
Eatin Fords-$hittin Mopar
Joined
·
178 Posts
Discussion Starter #1
Anyone else had any problems with a small oil leak right in front of the oil filter? The service guy pointed it out to me when I had it at Midas yesterday, but the technicians at two different dealerships didn't bother to tell me a damn thing when I was getting my oil changed there......Go figure.... Ba$tards!
 

·
Registered
Joined
·
1,329 Posts
Its not a leak of the filter itself. These remotes units are notorious for leaking at the connections, and if you use Synthetics the lines bleed. All the oil then runs around the filter and gathers at the bottom making it look like the filter is leaking, everyones 4x4's do it unless either they stop running syn's or replace the remote unit with and afterkarket one, Mine does it, it leaks about 1/8 of a quart each month since new, when I run regular oils it dont, so I just keep and eye on level.
 

·
Eatin Fords-$hittin Mopar
Joined
·
178 Posts
Discussion Starter #3
Thanks...

Thanks for the information. I knew it wasn't the actual oil filter that was leaking but I couldn't remember exactly where it was leaking from. In that same general area though. Is there anything that the dealership will be able to do to resolve this? I am still under warranty so I am going to call on that ASAP to get them to fix it on their dime.....

Thanks again!
 

·
Registered
Joined
·
1,329 Posts
I wouldnt think so. Its the product design and components they use. So they will us the same crap all over again, but why not let them change it. Maybe print a list from like ZR-2.com , they have a post of the same thing, maybe you could get lucky and they maybe for nothing or a few more $er's install and aftermarket one that wont leak.
 

·
Deadbeat
Joined
·
1,331 Posts
mulitple leaks

i had a couple of leaks around the filter when i started to run syn....once around a gasket where the the lines run to the filter and once at where the hoses are pressure seal to the fittings....dealership fixed it around 15k miles ago and havent had a problem since......
 

·
Eatin Fords-$hittin Mopar
Joined
·
178 Posts
Discussion Starter #6
Oil......Synthetic or Non-Synthetic?

That brings me to another question..... Would it be better to run synthetic oil in the 4.3 V6 or is that mainly a preference thing. I guess I have never heard anything really concrete about the advantages of synthetic oil.... Any tips or hints about what brands would give me the best protection?........ Thanks!
 

·
Deadbeat
Joined
·
1,331 Posts
synthetic

i used syn in my old ranger which i sold at 300,000 miles and it was a four banger......maybe it was the syn that help or maybe just luck,...i use syn in my s-10 4.3 just cuz of my good experience w/ it in my old ranger......
 
1 - 7 of 7 Posts
Top