S-10 Forum banner

1 - 10 of 10 Posts

·
harlem body kit has to go
Joined
·
1,170 Posts
Discussion Starter #1
i changed my sisters oil in her rav 4 and the autozone guy told me the wrong oil, he said 10w30, so we put that in and i realized before we started it it had the wrong oil. so i dumped that and put the correct oil in , 5w30. now when i start the car there's smoke coming out of the engine... i dont know what to do can someone please advise. thanks
 

·
UAH By-product
Joined
·
1,092 Posts
is it just oil burning off something? is it coming out of the exhaust? from the engine compartment?

smell like burning oil?

Brad
 

·
harlem body kit has to go
Joined
·
1,170 Posts
Discussion Starter #3
it could be. i did spill some. its coming from under the engine somewhere, yes i think its burning oil.
 

·
Registered
Joined
·
1,072 Posts
you might of spilt some oil on the block or somethin i wouldnt worry about 10w 30 and 5w 30 its not goin to hurt it if you put a thinner oil in it

just drink a beer and chill out everythin is cool
 

·
UAH By-product
Joined
·
1,092 Posts
then it'll mix in with the other and probably make no difference. try lookin around and seein if there is oil on it. Get some castrol super clean and a water hose after it.

Brad
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
yeah oil weight doesn't matter that much when it is 5w30 compared to 10w30.....don't even worry about it, you probably spilled some on the exhaust manifold

Caleb
 
1 - 10 of 10 Posts
Top