S-10 Forum banner
1 - 8 of 8 Posts

·
ELTC
Joined
·
8,391 Posts
Discussion Starter · #1 ·
ok heres the thread i already have started in the baggin it section. Ive hit a rut tho it seems and the thread isnt getting much attention so here it is for reference..
http://www.s10forum.com/forum/f125/devious-tank-pics-inside-couple-s-451368/

bit of info for ya. 2001 4.3 with just under 75K on it, with an 11 gal fuel cell/tank. has a 96 2 door Blazer pump assembly with 2001 S10 fuel level sensor and brand new fuel pump. level sensor change because 96 blazer assembly runs at much lower OHM. blazer assembly used due to depth of tank and stock assembly was a little too tall.. only thing i havent done with fuel pump assmbly was reuse the little black hose inside the assembly. not sure what that was for but the blazer pump assembly i used didnt have that like my stock unit did.

ive got plenty of cranking power my truck just wont start. full batt charge (deka intimindator) 8 gallons of gas in tank. pump turns on when u turn key on. fuel is passing thru fuel filter, fuel is reaching lines behind throttle body but still not firing. if i dump some gas in throttle body it trys to start but dies out almost right away. could i have fowled some plugs doing this?? even so wouldnt it still start just run like ass??!!

truck hasnt been running in almost a yr. ive started it a few times no problems since but out of the past yr it wasnt started for atleast 6 months due to rear frame being rebuilt and tank was out.. hope ive given enough info here, i need some help guys what should i look into for possible problem areas??
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
Well, for staters... if you dump some fuel in the throttle body it should run...briefly but, still run and quite well. So, I'd definately start by looking at the ignition system, in addition to checking all my grounds and for anything else that could be disconnected. A bad MAF will keep a vehicle from starting as well.
 

·
i saw what you did there!
Joined
·
3,573 Posts
whats fuel pressure reading at the rail?
 

·
ELTC
Joined
·
8,391 Posts
Discussion Starter · #4 ·
Well, for staters... if you dump some fuel in the throttle body it should run...briefly but, still run and quite well. So, I'd definately start by looking at the ignition system, in addition to checking all my grounds and for anything else that could be disconnected. A bad MAF will keep a vehicle from starting as well.
few weeks ago fuel dumped in to TB would get it runnin and it ran on its own for quite a while.. now nothin not even a hickup


whats the proper way to test fuel pressure? off the purge valve thing behind TB?
 

·
Sometimes I'm mean...alot
Joined
·
1,348 Posts
Test at the fuel pressure test port on the fuel line behind the large plug on the intake, ahead of the distributor.
 

·
ELTC
Joined
·
8,391 Posts
Discussion Starter · #6 ·
oki will. what numbers should i be looking for with key on and cranking?
 

·
ELTC
Joined
·
8,391 Posts
Discussion Starter · #7 ·
bump
 

·
Registered
Joined
·
8,782 Posts
Key on prime..... around 60psi, Key on Idling....... around same, blip throttle, should increse a bit - maybe 5 psi..... some people report lower numbers tho....
 
1 - 8 of 8 Posts
Top