S-10 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
so I recently changed the intake manifold gasket and I changed the oil from the milky coffee to fresh oil but my oil pressure gauge doesn't move when I start the truck. It wont move at all. Could this be a gauge issue or an oil pump issue? The truck doesn't over heat anymore and seems to idle fine. i haven't drove it since the gasket replacement so do you guys think its fine or something to look into. Also after i was done with the replacement the battery was dead. I have had battery issues before so I didn't think anything of it.
 

·
Been there Done it
Joined
·
7,040 Posts
Don't worry about the battery, you probably had a door ajar the whole time you were working on it. If you didn't disconnect the battery first like you're supposed to. When ever you work under the hood take the ground cable off before doing anything.
The oil pressure switch is probably disconnected back by the distributor. Or you might have accidently damaged it if it is hooked up.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
So I figured out it was my oil pressure switch but it seems to be completely gridlocked in there and I cant get it out 😂 Any suggestions?
 

·
Chopper! Sic balls!
Joined
·
39,360 Posts
If there's truly no oil pressure and the bearings are wiped the truck would be making all sorts of fun noises.
 

·
Been there Done it
Joined
·
7,040 Posts
You just had the distributor out, so you know how to do it. If it's running OK you did it right. Pull it back out for elbow room.
And as Rhotpursuit mentioned you hopefully changed the oil and filter. I'd do it again in a couple days because a lot of crud gets loosened up when R&R-ing the intake.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
alright guys I got it running good. I changed the sensor and the pressure is back to normal.(y)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
How long did you drive it with the milkshake in it? Doesn't take long to destroy the bearings.
It over heated on my way to work one day so when I got home I parked it until I figured out the problem. Not to mention I live less than 3 minuets from my work so she wasn't running on the crappy oil for long.
 
1 - 9 of 9 Posts
Top