S-10 Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
What next??
Joined
·
1,460 Posts
Discussion Starter #1
Ok, well im getting no heat in my truck...I'd try to chase it back down to the last thing i messed with, but i haven't used the heat in months! so i'd have a lot to check..the truck will sit right at 190 when its up to temp, that doesn't completely rule out a thermostat being bad, but after getting up to temp it would have heat...i don't know much about ACs, but when you turn the heat on like full blast, is the compressor supposed to be running to? mine does... anyways, what are some things i should start checking? thanks - Chris
 

·
Registered
Joined
·
619 Posts
Some vehicles with ac have a heater hose valve that shuts off flow to the heater core when the ac is on...... ive seen them go bad

If you have dexcool in your system it could have plugged the heater core if the dexcool started to solidify
if the truck is old, it may be plugged due to age

Make sure your system is full of coolant

Make sure the heater core isn't air bound

The ac compressor is to run generally only when the defrosters are on, but some models might run when the heat is on high.

Heater controls/ducts may not be working

if it sat for a while, mouse nest in the blower and heater core

see if both heater core hoses are hot when the truck is fully warmed up
 

·
What next??
Joined
·
1,460 Posts
Discussion Starter #3
When you say the heat core hoses should be hot..do you mean like, hot to the touch? i was out there tonight and i had the heat turned on all the way, but i think i had defrost on, i didn't know the compressor ran when that was on..i thought it just meant it blew all the air on the windshield..anyways, i touched both the lines and they wern't hot at all, hardly even warm, just from the heat of the engine..
 

·
ask me about my crabs
Joined
·
81 Posts
If the heaters hoses aren't hot there is one problem you need to see why those don't heat up cause the should burn almost when you touch them, they have engine coolant running though them.
 

·
What next??
Joined
·
1,460 Posts
Discussion Starter #5
Ok well after driving for an hour today, i got home, tryed the heat..i get alittle heat..so i check fluid, i think its just way low, the the heater lines get kinda warm..can i just add more dacron to the stuff that is in there already? there is dacron now, just not sure if its ok to add more to it..
 

·
Registered
Joined
·
619 Posts
you mean dexcool? you can just add more, but dont mix it with the green stuff. If the dexcool in your system is brownish and staining everythiing you should flush it and replace it completly with green stuff or just stay with the dexcool
 

·
What next??
Joined
·
1,460 Posts
Discussion Starter #9
Ok well, I have heat now! I pulled the 2 heater hoses, and backflushed the heater core...water was flowing but slow..then all the sudden, it started gushing..so it was just clogged. Just thought i'd let ya'll know incase someone else has similar problems..Thanks for the help
 

·
Registered
Joined
·
2 Posts
Some vehicles with ac have a heater hose valve that shuts off flow to the heater core when the ac is on...... ive seen them go bad

If you have dexcool in your system it could have plugged the heater core if the dexcool started to solidify
if the truck is old, it may be plugged due to age

Make sure your system is full of coolant

Make sure the heater core isn't air bound

The ac compressor is to run generally only when the defrosters are on, but some models might run when the heat is on high.

Heater controls/ducts may not be working

if it sat for a while, mouse nest in the blower and heater core

see if both heater core hoses are hot when the truck is fully warmed up
I have 1 hot heater hose other one is cool to the touch temp id running a lil high but come down under throttle system seems full
 

·
94 4x4,01 Blazer
2001 Blazer 4dr 4wd LT
Joined
·
1,190 Posts
start your own post- this thread is 17 years old... and read the rules.....
 

·
B4U Task Force Admin
Joined
·
25,266 Posts
start your own post- this thread is 17 years old... and read the rules.....
While I appreciate the help, please supply a link to the rules.


#10 & 12 seem to be the biggest problem.
Thanks
Rick

Closed.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top