S-10 Forum banner

1 - 10 of 10 Posts

·
NOT DONE TO MANY PROBLEMS
Joined
·
1,566 Posts
Discussion Starter #1
I went to drive my truck into town for the car show a while back after being torn apart and now the turn signals don't work. The weirdest thing is when i turn on the headlights both blinker indicator lights are on, solid! What could cause this? Would it be the blinker relay thing? I have a parts truck that i think might have one just haven't had time to switch it out. What do you think? thanks
 

·
no longer has a 95
Joined
·
1,883 Posts
It is normal for the lights to be on solid when the running/headlights are on.

I would try the blinker parts from the other truck and see if that works. What all did you have torn apart?
 

·
Registered
Joined
·
647 Posts
check the sockets... the terminals in there get really corroded after time, and once you touch them, its nothing but problems. i had this problem with my 1991, after replacing the bumper
 

·
NOT DONE TO MANY PROBLEMS
Joined
·
1,566 Posts
Discussion Starter #5
i am not talking about the side markers staying solid. I am talking about when you look on the dash where the turn signal INDICATORS are. Those are solid green on all the time not off like they should be. I will try some new bulbs and if that doesn't work i will try the blinker switch. I didn't mess with any thing while the truck was apart just sheet metal things.
 

·
Ex-Import Lover
Joined
·
893 Posts
mine keeps blowing the turn fuse. and my like door alarm doesn't work. like when you leave the lights on after you shut it off. it doesn't BEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEPPPPP
 

·
Registered
Joined
·
53 Posts
cut your lights on and check all your bulbs to see which one of your lights are blown or not hooked up right...that is more than likely the problem. i had that problem with one of my mine and when i cut my headlights on the arrows would stay solid cause the front left blinker bulb on the bottom was blown, the one in the bumper. that is an indicator to let you know its blown, the arrow staying solid.
 

·
Registered
Joined
·
655 Posts
after i had my truck all torn apart (bed off, etc...) i had a similar situation thing happen to me as well. anyway, i had to temorarily put things back together so i could drive the truck around to get emissions done and whatnot, so i skipped bolting down a few things. and as a result my blinkers didn't work properly, brake lights worked only when the headlights were off - it was ****ed up. i checked everything: fuses, relays, bulbs, wires. nothing worked. anyway, i got the truck put back together again (properly this time) and now everything works like normal again.


so long story short, i think you might have a bad ground somewhere. good luck, man!
 

·
Truck #121616
Joined
·
2,860 Posts
mine keeps blowing the turn fuse. and my like door alarm doesn't work. like when you leave the lights on after you shut it off. it doesn't BEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEPPPPP

i hate the door beeper :p

i cut the wire for mine. i like to be able to leave my doors open when im playing music (more sound to the back of the truck for tailgaters) without the stupid droning beep sound.


and my green signal indicators stayed solid on once, turns out i had a burned out bulb and a toasted relay.


ive got another problem now though... when i turn the high beams on, the left signal indicator likes to wig out and turn on/off very quickly... im thinking i didnt hook something up properly... (had a P2S button, and switches for the truck, went back to the key start). The indicator didnt do this until recently...
 
1 - 10 of 10 Posts
Top