S-10 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey guys just posting for the 2nd time in a long time. I joined for tips and pointers on doing my s15. I bought the truck back in March and spent the summer redoing the front suspension and installing a free to me 305.

I learned a lot while doing it, especially from this forum and am grateful for everyone documenting their builds. As of last Thursday the truck is inspected and tagged in my name, I can now drive it whenever but still have a lot to do.

In addition to replacing the 2.8 with a 305 I got a 700r4 with the regular bell housing, a summit s10 v8 exhaust kit, Hedman v8 swap headers and translators mounts. Put a summit k1103 cam, high volume oil pump and a new pan gasket on it. New shocks and new bushings, djm drop spindles in front and beltech drop blocks for the back, ball joints and all new steering pieces including the keep steering shaft upgrade.

Due to the tight clearance at the front I dude the old Intrepid fan swap and recessed the radiator into the core support. I also had to convert from column shift to floor shifter because of header clearance.

I'll try to post some pics if the forum will let me.
 

Attachments

·
Administrator
Joined
·
20,896 Posts
Welcome. Please save your tech questions until you have access to the rest of the forum. After three posts and a short wait for the system to do its thing…about an hour, you should be free to roam about and post in the appropriate forum for your questions.

As for the thumbnails...some load...some don't. That aside...a lot of members don't like them because you have to click every stinking pic to see them. On a pic heavy thread, patience wears thin and they move on.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks, it's been a while since I've posted to forums. I guess I need to fire back up my photobucket account so I can link to pictures instead of using the thumbnails.
 

·
Administrator
Joined
·
20,896 Posts
Photobucket is not an option anymore. They are holding pics hostage unless you pay $$$$ for third party hosting
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Is there anyone with a 2.8 truck that can get me a picture of the temp gauge sender wire? I believe it's green and connected to the same piece of harness that controls the AC compressor. I can't get my temp gauge to work and must be using the wrong wire.
 

·
Boozebag
Joined
·
8,995 Posts
Welcome!


The temp sender wire is green and it connects to a sender at the back of the driver side head on a 2.8. It comes out of the harness a little to the driver side where the distributor on your 305 is.


Truck looks good. Usual Texas fade...
Bonus of zero rust!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Thanks is it in the same loom as the ac wiring? That's where I'm stuck, if not there are two green wires. Truck seems to be cool enough as the e fans come on and off based on temps from the controllers. I just hate not knowing how hot it is, guess I'll be chasing wires.
 
1 - 10 of 10 Posts
About this Discussion
9 Replies
3 Participants
Rhotpursuit
S-10 Forum
S10forum is the community to discuss the S-Series, Chevrolet Colorado and GMC Canyon. Join to discuss rebuilds, modifications, tech articles and more!
Full Forum Listing
Top