S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
A couple weeks ago, my AC mode selector switch (used to select MAX A/C, NORM A/C, HTR, etc.) grenaded itself behind the dash and made my AC unusable on a hot afternoon after work. So after a bit of frustration, I get the switch and all of its components removed from inside the dash. With the temperature selector cable removed and all wiring harnesses disconnected, I installed a new Standard Motor Products selector switch. It only goes in 1 way and can only connect to 1 lever that can only select 1 mode at a time. So I'm fairly certain I don't have it in wrong, and the wiring harness plugs in smoothly.

But, this is the issue I'm having:
When I select MAX A/C: The truck thinks it is in HTR mode with no compressor action, but the vent doors function like MAX AC
Norm AC: Normal AC vent mode, with NO compressor (truck thinks it is in vent mode)
BI-LEV: functions normally as it is the middle selection
Vent: Normal A/C compressor action with vent-only blower selection
HTR: Compressor cycles as if it's on MAX ac, but the fan only blows on your feet and at the windshield, as if it was actually on HTR.

BASICALLY, BOTTOM LINE: The vent doors open properly depending on the mode I select, but the AC modes are reversed??? Faulty switch or what? I'm scratching my head on this one but I don't want to order another switch if I'm just hooking something up wrong. I don't see how I could though.. I don't believe it's a vacuum leak either unless I could have possibly pulled one loose while messing with the cluster??? I thought the hoses were long enough as I only pulled the cluster out a maximum of 3 inches. Would an HVAC vacuum leak even cause an issue like this? I just need to know where to start, because having a max ac mode that only blows on your legs sucks. This is a really hard issue to explain and I would be totally open to posting a youtube video if you think you can help me but just don't quite get what's going on.
 

·
B4U Task Force Admin
Joined
·
25,274 Posts
Moved to Heating/Air Conditioning.
 

·
Been there Done it
Joined
·
8,964 Posts
Why doesn't that surprise me? Probably a Dorkman part.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Update FYI it turns out the switch that both Autozone and orileys sells is not correct.
Hey man, sorry for not replying to your previous post. I got mine from standard mfg. and I guess it must be wrong too. Did you end up ordering another one that worked properly? If so what brand? It’s been really annoying to have half-a**ed AC for the last few months since MAX AC is no longer functional with the faulty switch. Glad you got to the bottom of it!
 

·
Registered
Joined
·
6 Posts
Hey man, sorry for not replying to your previous post. I got mine from standard mfg. and I guess it must be wrong too. Did you end up ordering another one that worked properly? If so what brand? It’s been really annoying to have half-a**ed AC for the last few months since MAX AC is no longer functional with the faulty switch. Glad you got to the bottom of it!
I “repaired” my original switch for now but I ordered one on LMC I’ll let you know if it works correctly
 

·
Been there Done it
Joined
·
8,964 Posts
LMC isn't any better than anyone else when it comes to quality. They have a lot of offshore items.
 
1 - 8 of 8 Posts
Top