S-10 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey guys, new member to this forum but not to s-10's. My problem is I have the clear tailights on my 98 s-10 and hate the red bulbs to put in there. They always burn out or turn white, so I wanna go with some LEDs. I bought some APC LEDs, installed them (the correct way too because of polarity) and they kept on blowing ALL of my fuses associated with the lights (like the brake fuse, turn signal fuse, etc.). I changed all of them to 5 amps above what they were, and same thing, blowing them all. So here's my question guys: is it the APCs (cuz they're so cheap) or am I just missing something totally apparent that I should be doing? Also, if anyone has installed them before on their 98+ s-10, please give me some advice on things you did or what not. And lastly, if anyone has any suggestions on good brands of LEDs for the rear taillights, let me know them (other than Hz Engineering).
Thanks,
Steebo
 
K

·
Guest
Joined
·
0 Posts
it could possibly be that the LED's are not to blame, it is possible you have another problem that could be blowing the fuse, such as a shorted wire, and a question does it blow the fuse as soon as you hit the brake or just blow whenever? :confused:
 

·
Future Submariner
Joined
·
37 Posts
yea cant be the leds

hey man most single leds draw 0.020 Amps...you would need 50 leds to draw 1 (one) amp....be carefule you must have shorted something....also i remember reading something about needing new flasher/relays but i dont know if they matched the impedence of the led bulb with the regular one......just besure to check you grounds b/c leds dont use that much current
 

·
Registered
Joined
·
1,832 Posts
How about you put the old bulbs back in and see if you keep blowing the fuses... then you will know if it is the leds or something else.

DogP
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Yeah I put the old lights back in, and they work fine now. That's what makes me believe I bought some shotty LEDs. Thanks in advanced for the help!
-SteebO-
 
1 - 6 of 6 Posts
Top