S-10 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hey, i noticed my 1995 s10, 4.3L Auto has fits where it idles really weird, no one had ever seen it but me, then yesterday, while at work my cousin was working on it and it did it to him, it just so happens he had my camera in the truck.

Link: http://www.youtube.com/watch?v=-a7mwdnFaYs

Any information will help greatly!
Thanks.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
I also heard it could be a vacuum leak or a in need of a fuel regulator.. Any ideas ?
 

·
Budget Ballin FTS!
Joined
·
3,652 Posts
Check for a vacuum leak, can be something simple. If not I would hook it up to a OBD2 scanner and see if its throwing codes. Your local advanced or oreilies can scan it for you for free... Or is that just mine that does that? lol
 

·
Registered
Joined
·
207 Posts
Check for a vacuum leak, can be something simple. If not I would hook it up to a OBD2 scanner and see if its throwing codes. Your local advanced or oreilies can scan it for you for free... Or is that just mine that does that? lol
you can buy a OBD2 scanner at Harbor Freight for less than $100. I have had one for several years. They work great.
 

·
Registered
Joined
·
1 Posts
Hey, i noticed my 1995 s10, 4.3L Auto has fits where it idles really weird, no one had ever seen it but me, then yesterday, while at work my cousin was working on it and it did it to him, it just so happens he had my camera in the truck.

Link: http://www.youtube.com/watch?v=-a7mwdnFaYs

Any information will help greatly!
Thanks.
:rant:OH MAN! I do feel your frustration and pain! I just had this happen to me on my 95 4.3 S10 Auto. May I ask what he was working on or doing to it? Mine has started after I did a complete engine swap as the original one was siezed solid. Come to finally find out when we replaced the plastic timing cover, there are 2 steel dowl pins that go in the block and then into the cover. That cover also has the Crankshaft sensor in the bottom left of it with 3 pins, held in by 1 8mm bolt. When replacing the Harmonic Balancer and then the cover the new cover has enough 'play' in where it bolts down so that the Crankshaft sensor is rubbing on the gear inside. As this is only 1 of 2 possible sensors that control your tach. After pulling that sensor out and looking at it, I can see where mine was rubbing...Long story short, the fix is to remove the fan, waterpump, timing cover, loosen all the oil pan bolts(removing the first 4 at least on both sides) to drop the front of the pan as the new cover on the bottom fits inside the oil pan gasket, bolt down the cover, tighten the pan up, put water pump back, fan back, etc. Then you will be down. That sensor has to sit within very close proximity to that gear to 'sense' it but too far out will kill the motor and too close basically grounds out the system and your brake lights, dummy lights etc will go all awhack along with a JUMPY, BOUNCY tach as it can't read it right. :cool:Hope that helps man. Good luck let me know, Scotty
 

·
registered loser
Joined
·
296 Posts
I have a 95 4.3 tbi automatic. I don't have a tach but just judging by noise mine was doing the same thing. rev high, then low, sometimes stall, lights dim... all that stuff. turned out it was the Idle Air Control Valve (IAC)

It only seemed to cause intermittent problems... one day it would be fine, the next day I would stall at 3 traffic lights in a row. It only caused problems before I got up to operating temperature (70-75 degrees) I busted my IAC trying to clean it but I put it back in cause my truck wouldn't start without it. I stalled at every red light and had to two foot it to keep it running to get to the parts store. as soon as I hit operating temp it calmed down and would hold an idle... unfortunately I still had no power but its all good now.

i see from your video you have a Canadian truck, where are you from?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #9 ·
Thanks for all your feedback and help guys, i'll let5 you know what works!


@Worldwide, How can you tell ? D:
and Ontario, just outside of niagara falls.
 
1 - 10 of 10 Posts
Top