S-10 Forum banner
1 - 7 of 7 Posts

·
Big Ran
Joined
·
38 Posts
Discussion Starter · #1 ·
So I have a '96 Sonoma that started as a 4.3L. I swapped in a 350 motor (not sure on year, but has centerbolt valve covers if that helps). All of the 4.3 pulleys and stuff bolted right up to the front of the motor, except the water pump. So I got a new water pump and I think it was from a late 80's G20 van or something, I forget. With everything installed, it all works great, but the alternator sits up too high since it's bodydropped. It has the tensioner pulley as well as the power steering pump pulley but has no A/C or idler pulley.

I tried another alternator bracket but it doesn't work. My water pump does not have this mounting hole that I see every other water pump have, it's weird. I ordered another bracket but I don't think it's going to work either. It will be here today so I can post more photos once I have everything disassembled. I know I'm going to have to run a cowl hood to clear the air cleaner, and that is fine. Actually, I should have the hood this week to do some test fitting, but I know the cowl will not clear the alternator. These are the only pics I have right now. I hope someone on here has ran into this problem and knows a solution. I might just have to have someone custom make me one. Thanks!





old water pump...



 

·
http://www.vicbaggers.com
Joined
·
4,246 Posts
I would do the alt bracket w/the heim joint.not sure what they call them, March, etc.. makes them. But you'll have to get the STD rotation pump & change a few things up. I ran into the same problem, when I 1st did the body drop w/the stock 4.3 & brackets..that's why I went carb'd & did the V-belt & brackets..

http://www.marchperf.com/pg7.html
 

·
Big Ran
Joined
·
38 Posts
Discussion Starter · #3 ·
i bought this same bracket from summit (summit brand):




where that "heim joint" mounts onto the water pump, i do not have that bolt hole. it also doesn't have the 2 mounting holes at the bottom for the lower bracket. also, i have a stock 4.3L alternator and that looks like a chrome v-belt 1-wire alternator, so i have like 3 mounting holes on my alternator. only thing i can think of besides buying a whole new front setup (and spending a lot of money) is having someone custom make something.

damn bodydrops and v8's. LOL
 

·
http://www.vicbaggers.com
Joined
·
4,246 Posts
Your water pump is a reverse rotation..the serp belt rides on the back side..you need a standard rotation, for that bracket to work. Get one form a 86 C10 350 lets say..one that came w/a a v-belt. That's what I used.
 

·
Big Ran
Joined
·
38 Posts
Discussion Starter · #5 ·
ok thanks. i'll check that out. will that be a short or long pump? i have a long one now. and will i need to switch everything to a v-belt or be able to put my serpentine pulley on the front of that pump? i think i will still need to stick with a long pump or the water pump pulley will be sitting too far back to line up with the other pulleys. sorry for my lack of knowledge on this. lol
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top