S-10 Forum banner

1 - 6 of 6 Posts

·
Just a member
Joined
·
6,626 Posts
Discussion Starter #1
OK a few days ago my passenger front brake started grabbing. I had a oversized spare on the front for about a week. I thought maybe that was throwing off my ABS. But after I put the old tire back on, it still does it. I even reset the computer hoping it would reset the ABS sytem, but no go. It only grabs when the truck is almost coming to a complete stop. It also makes a noise like the ABS does when it is grabbing. Sometimes the brake pedal bounces back with resistance and does not stop at all. Just yesterday my ABS light starting coming on and then going off. And sometimes when my ABS light is on, my emergency parking brake light is on too. The thing is that when my ABS light is on, the truck stops fine and does not grab or nothing. But as soon as the ABS light goes off, it starts grabbing again at slow speeds. I have looked at the ABS sensor on that side, and it seems OK. I do not know what else to try at this point. Any help would be appreciated. Thanks
 

·
Color Changin Member
Joined
·
1,375 Posts
Hrmmm.........I dont understand what could be wrong with it. Now might be the time to get a new unit (I have one you can buy :) ) or you can do what I did and take it out. You can always make your way to the chevy dealership or some repair shop and see if they can find out what is wrong with it.


Bob
 

·
Shit's Weak
Joined
·
1,970 Posts
i have the same problem with both the abs and emergency light coming on. it doesn't always come on and if i shut it off and restart it again quickly, they both stay off. someone told me its because i have 50 series tires in back and 45 up front. this makes sense because the abs is set for the overall diameter of all 4 wheels to be the same. i don't know what to tell you man, let the lights stay on if the truck runs fine with them on, abs licks balls anyway.
 

·
Just a member
Joined
·
6,626 Posts
Discussion Starter #4
Thanks for the help guys.

Yeah SlowBlue00 I was thinking of removing the ABS as an option. But I have never done this on an s-10. I am sure if I can find the info on how to, I can do it.

jhorton I thought that the tire size was issue too. I have always ran the same size tires, until I used that oversized spare. I thought that was the issue, but my old one is back on the truck and still the same issue. As far as the ABS light. It goes off and on. I wish it would stay on. Atleaste when it is on, my truck stops normally again. But it will clear itself at anytime and then the grabbing breaks start again.

One more note I forgot to add in the first post. One other odd thing I have noticed it does when my brakes grab, is that it pulls from my electrical. When the brakes grab and the ABS messes up, my lights dim and everything.
 

·
Just a member
Joined
·
6,626 Posts
Discussion Starter #6
Well until I get the time take my front end up in the air, I have unplugged my ABS so to say. It stops fine now, I just have to put up with the ABS light always on.
 
1 - 6 of 6 Posts
Top