S-10 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
MY truck stopped on me, i was going to werk and it backfired, a couple of times then booom a big back fire!

i thought i ran out out of gas again cuz it happened b4 cuz my gauges dont werk right, well it wasnt .
anyway we went under the hood , changed the plugs, and the ignition module, and the distributer cap and rotor cuz it wasnt throwing a spark, it was turning but not all the way over. anyway wen we changed all that at least it threw spark, my arms got proof of that, but it still wont start. now i had a mechanic come over and he said that its prolly a fuel pump right and at first im like yeah, but i then i rember i sprayed starter fluid into the carberator and it didnt start, i had my truck being jumped by a nother car and really sounded like it was gonna start but it didnt.
question is if it was the fuel pump then wouldnt have the truk had started wen i sprayed starter fluid or gas in the carberator, then it cant be the fuel pump right, but we couldnt hear the pump running in tank ethier wen we turned on the igition.
also could it be the computer, or it is to old to be the computer?
 

·
Registered
Joined
·
498 Posts
I'd think with a bad fuel pump it would have just quit. Weak ignition would have warned you for some time. I'd guess you got a broken timing chain/gear or something that caused it to jump out of time bad. Hook up a timing light and check for correct time. Should run on starting fluid like you tried if it was fuel related.
 
1 - 2 of 2 Posts
Top