S-10 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
been a while since i've had to post here as the Bravy has been running great! BUT, now she has dcided to have very odd idle tendencies. you start her up, and the rpm goes up to about 1500, then drops to 1100, then down to about 600. that's where the idle is. but why does it drop down in 3 very seperate incriments?
AND
say i pull up to a stop sign, and am sitting there, all of a sudden after ive been completely stopped for like 4-5 second it'll jump like 500 rpm and my car actually moves foreward with the break pressed.

any input would be greatly appriciated as i really dont want to rear end someone when my car decides that it wants to move forward.
thanks,
reed
 

·
Registered
Joined
·
247 Posts
Don't worry you are not the only one that has this problem. This is a problem the majority of S10 owners have. I can't remember if GM recalled the problem or not, but just do a search. There was a thread awhile ago about this problem.
 

·
Clean N' Dark
Joined
·
1,921 Posts
Sounds like your IAC sensor is acting up. I had the same problem.

When warm the truck's idle would lock out at 1200rpms. After a cleaning and readjustment, 750rpms no problem.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
iac sensor? please explain what this is and how/where i get it checked.
thanks
 

·
Registered
Joined
·
37 Posts
Its the TPS..Throttle Position Sensor.. located just to the right of the throttle. (you have to remove the intake tube to get to it.) I just replaced mine last week because i would let off the gas sometimes, and it would just keep going!! You should also clean your Mass Airflow Sensor, and check the Map sensor as well, usually they add to this problem. I bought the TPS off Ebay for about 9 bucks. Im pretty sure that they are all the same for all 96 and later vortech engines. It costs about 30 dollars at NAPA though.
 
1 - 6 of 6 Posts
Top