S-10 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
375 Posts
Discussion Starter #1
ok, I was driving the other day, and all of a sudden, My brake peddle went all the way to the ground almost... I could still brake somewhat but it wasn't the same and then my e-brake light came on....


Then later when I drove it again, it still happen, but also there is this odd noise when I start to push the brake peddle.
It's not coming from the pad or anything like that.... it kinda sounds like the master C.

i checked the brake fluid and it was alittle low, so I filled it like 2 days ago, and it is still doing the exact same thing!
nothing different!

Any one have any ideas? I mean it's a 99, so it shouldn't be my Master C..... Hopfully not!

thanks for the info...

jake
[email protected]
 

·
Afterhours Admin
Joined
·
27,121 Posts
Whats this got to do with 2.2L engines? moved..

Anyway, it sounds like you might have a kinked hose or possibly one that is split. If you lowered the truck, check both brake hoses in the front for damage, but also check the one coming off the frame to the differential. When the truck is lowered this hose may rub on the charcoal cansiter causing it to break down and possibly wear thru. If eberything seems to be alright, then maybe you have some air trapped in the system.
 

·
I hate you
Joined
·
2,241 Posts
I thought this sounded like the one I replied too earlier.......

You might have a leak somewhere, I busted one of my rear brake lines at the drum and it did the same thing, check all the connections and the rear wheels for fluid.
 
1 - 3 of 3 Posts
Top