S-10 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I'll get right to it. the driver side bumper turn works (lights up) but does not blink... ever. One of my brake lights does not work. One of my back up lights does not work. I checked the fuses but they seem to all be ok. Am I missing a fuse somewhere? Am I looking in the wrong area? One more thing... this might be normal.. I don't really know... when the hazards are on, and I put my foot on the brake, the hazards stop. Somebody please help me with this annoying problem. Thanks, I appreciate any response.
 

·
Registered
Joined
·
2,108 Posts
1st off, yes it is normal for your hazards to stop blinking when you step on the brake.
Now i have some question's....
1) do any of the blinkers flash?
2) do the blinker indicators in the dash...a) flash b) stay on solid or c) not come on? Oh and do both side do the same thing or different things?
3) If some of your lights flash, do they do it with the tern sig. or with the hazard switch.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Everything works fine. The dash lights work (at the correct pace, so there isn't a bad light on the circuit) all rear blinkers work. On the passenger side the bumper and corner lights blink. On the driver side, the bumper light is on when the lights are on, but does not blink when it is supposed to.

Thanks for the reply
 

·
Registered
Joined
·
2,108 Posts
well, if I was you, I would remove the bulb that stays on and the brake light bulb so as to remove the load. then test the socket with a volt meter with the blinkers on.....hmmmm that my not work, damn. Ok try this.... on the front bulb that doesn't blink find the ground wire, splice in another wire with an alligator clip on it and use it to ground that bulb to a new place. Use something you know has a good ground. If that fixes the prob, you have a weak ground. If it doesn't help, its prob your multi function switch.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
I know that I have a good ground, but where do I find this multi function switch, also, is there another set of fuses that I don't know about other that the set on the side of the dash?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
damn! I still can't find the deal here. I'm thinking I just might have to take it in to a specialist. Don't really want to spend money though. Probably gonna be about $200+.
 

·
Registered
Joined
·
2,367 Posts
I assume you've tried a new bulb where a bulb does not light up?
 

·
Registered
Joined
·
335 Posts
Well it sounds like you're low on blinker fluid. jk. But the only thing that comes up in my mind is a burned out bulb.

-Adam
 
1 - 11 of 11 Posts
Top