S-10 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
531 Posts
Discussion Starter #3
ok im keeping it i broke the wiring harness for it when i pulled the motor and no one sells it im lazy to drive to the auto wrekers hahah thanks man
 

·
QuickerPICKerUPer
Joined
·
302 Posts
The only way not having a knock sensor plugged up is going to hurt your engine is if is already knocking to begin with. It wont have timing problems, it wont loose gas milage and it wont run too rich or too lean. The knock sensor does not control any of this, it will just send a signal to the PCM if the engine is knocking to retard timing. But definately get the harness fixed. It can save your engines life (if its running bad)
 

·
Insane Network Engineer
Joined
·
5,965 Posts
Umm, you're a bit off there Red... You will loose gas miledge, and you can run too rich or too lean.... The knock sensor as you sead will advance or retard timing based on noise coming from the engine... I've seen 2 motors go bad because of knock sensor failure running for too long...
 

·
Registered
Joined
·
448 Posts
RedGT said:
The only way not having a knock sensor plugged up is going to hurt your engine is if is already knocking to begin with. It wont have timing problems, it wont loose gas milage and it wont run too rich or too lean. The knock sensor does not control any of this,
WRONG!!
This is bad advice.
I have disconnected it to demonstrate to a customer how important the knock sensor is.
You need it.
 

·
Registered
Joined
·
15 Posts
agrees with rlith..... father inlaw had an engine replaced with a rebuilt. 4.3 went from 17 mpg to 8 mpg. ended up being the knock sensor the garage put in was the wrong one. ran way to rich. 2nd mechanic said if he'd ran it like that to long may have phucked up the cat.

my 2 cents
 

·
Quicker than a Hummer!
Joined
·
349 Posts
the answer here IS:

If you delete it, computer catches a ride on the short schoolbus- i.e. retards timing and increase injector pulse width.

RUNS RICH IN DEFAULT MODE.
 

·
Clean N' Dark
Joined
·
1,921 Posts
shortbud, retard timing.....

LMFAO!!! Good one!
 

·
QuickerPICKerUPer
Joined
·
302 Posts
Ok maybe you guys are right, I can just go on what the GM scanner and Service manual books say. When I intstalled my motor, the rear knock sensor connector came back off (the one you cant even see) It was not running bad and all engine data was normal. It dident have spark retard (maybe because I still had the other sensor connected)
I definately dident see the engine running rich, the O2 sensors were jumping back and forth regularly, nor did I see bad gas milage (I was driving it for a week trying to fix it in spare time)
I admit Im not always 100% and I wasent saying delete the knock sensor thats a bad Idea. And hopefully I can correct you guys in the future:finger:
J/K :lol:
 

·
Registered
Joined
·
3 Posts
Where is the second knock sensor located on... 93 4.3l ???? I found the first one on the driver side near # 3 spark plug !!!!
 

·
Registered
Joined
·
796 Posts
There is a knock sensor in the back of rhe passenger side head. It has a 3/8"-16 standard threads. The knock sensor between #1 and #3 spark plug has 3/8"-18 NPT. The thread is dfferent so you cannot install the wrong sensor. They are tuned to different frequencies.
 
1 - 12 of 12 Posts
Top