S-10 Forum banner

1 - 9 of 9 Posts

·
Registered Slacker
Joined
·
3,439 Posts
Discussion Starter #1 (Edited)
okae i got my DEI Viper d1200.1, i installed it the day i got it...it was night time so i couldnt set the gains and stuff in my garage cuz i know that the neighbors would come out and yell at me..so i took a drive...well, everything was perfect..truck came on, hu came on, AMP came on..green status light and all....
okae, i was driving..and was playing with the bass knob..okae.
then i popped in a better CD and i turned it up; loud...
i then turned the bass remote knob thingy up ...i wanted to see were i could turn it up and not hear any louder bass...it actually went all the way..and it just got louder..then i turned it down imediatly...i only had the knob up for like 3-5 seconds....
i was impressed..it sounded louder and way cleaner than my Hifonics....
as i kept driving..it was still on..every thing perfect..i didnt set any gains yet cuz i was gonna go to this spot were no one would be around so i can just blast away with out anyone yellin at me.....
well i kept driving ..then i came to a stop light..and i was like hrmm..i wanna play with my new toy...well turned around and i noticed that my amp was off..no red light, no green light..and no lighted up logo....i was WHAT THE FCUK? WHAT THE FCUK DID I DO WRONG NOW?
so yea i got to the spot..i turned off the truck..this and that..and it still wouldnt come on....
so i went home..slept..went skoo..i and thought..give it a day....
after skoo..turned on my truck to go home..and still no lights on the amp...i dropped off my girl..then i went straight to my playground(the car audio shop). i figured that the problem would be my ANL fuse and that it could be to much..cuz i have a 200ANL fuse..........so i asked the guys if they could show me were it's at...they did and they asked what kind of amp i got..i told em DEI Viper 1200w...
i told the guy wat had happened..he said it must be the fuse..and that it could have popped...he reconmend a circuit breaker..but i decided to let u guys tell me i need one......i bought a new 200ANL ampfuse cuz he said that i should be fine with it...
well i got home and changed it...and still nothing..nada..not even a blink of light...as if there was not power goin to it .....i have no clue on wat to do now...i even felt like selling all my stuff..sh!t..ugghhh *long sigh*
can someone help me? again? Thanks if any..and please dont bring bullsh!t i cant use like flaming and stuff..if i get it working then i'll let u guys flame me for being stuff and wat not..thanks again..
 

·
do it....NOOOOWWW!!!
Joined
·
674 Posts
did u check the fuse on the amp? the ground? that sucks dude...seems like you have the worst luck with stuff...
 

·
Registered Slacker
Joined
·
3,439 Posts
Discussion Starter #3
BiGB7184 said:
...seems like you have the worst luck with stuff...
:werd:

yea i checked the ground..i even made new ground..i bolted the ground to the back wall..it goes from the inside of the cab to the outside...that should be suffiecent..
there are 3 30a fuses on the amp..lol there a bitch to take out..i cant even take em out..
 

·
do it....NOOOOWWW!!!
Joined
·
674 Posts
03 S10 eXtreme said:
there are 3 30a fuses on the amp..lol there a bitch to take out..i cant even take em out..
open your lil fuse thing on the drivers side beside the vent, there should be a little yellow thing for pulling fuses out, im not sure if it will pull out amp fuses sinc ethey are bigger, but hey its worth a shot
 

·
Registered Slacker
Joined
·
3,439 Posts
Discussion Starter #6
lol kae i tried that..i still couldn't take the fuses out..but then while i was tryin to take em out..i saw something kinda funny in the fuses..
i got my flash light and i looked real good...THEY FCUKIN POPPED lol it was kinda funny cuz i realized that it wasnt the WHOLE AMP..just the fuses...so i had 3 30a fuses all popped lol...imma replace em tomorrow..how can i prevent this from happening again??
if i got a circuit breaker by the battery, would that help?
THANKS A WHOLE LOT BIGB1784!!!!!!!!!!!!!!!!!!!
 

·
Registered Slacker
Joined
·
3,439 Posts
Discussion Starter #7
kae wait till i get it workin..then everyone is welcome to flamming me about how im such a lil bitch..heh... :finger:
 

·
do it....NOOOOWWW!!!
Joined
·
674 Posts
haha your welcome man...tips to avoid blowing them.......QUIT ****ING WITH YOUR GAIN/BASS KNOB lol
 
1 - 9 of 9 Posts
Top