S-10 Forum banner
1 - 2 of 2 Posts

· Registered
1994 S10, 4.3 Single Cab, 100k Miles
Joined
·
20 Posts
Discussion Starter · #1 ·
So I have stock 94 paint that is crazy clean, The problem is my backyard is the Atlantic so I wash it 3 times a week. Will that mess my paint up even tho it has a thick layer of wax on it. Was thinking the washing would damage the wax not the paint,🤷‍♂️But I’ve heard otherwise.
Automotive parking light Tire Wheel Sky Vehicle
 

· Registered
1994 S10, 4.3 Single Cab, 100k Miles
Joined
·
20 Posts
Discussion Starter · #4 ·
You say Atlantic, perhaps implying that salt residue from the air and sand granules are the main thing you're washing off. Your photo is in an area that does not have the kind of trees that drop sap mist onto cars, and probably not a lot of muddy dirt roads to kick mud up onto the lower areas. Birds, birds, you may have issues with those.

In any case, I live 1/2 mile from salt water, On a ridge above the ocean, in ME, so I may have similar experience. I just hit the vehicle with a hose often. Sand, even small pieces you can't see readily, is death to paint, you want to never be doing any rubbing before the sand is hosed off. And salt does not actually stick to the paint. You may not have anything that sticks to the paint, so you may not need to use soaps and scrubbing. Without scrubbing, the sand is not an issue, without the chemicals your wax should last longer. I'd just hose it off more often, with the highest pressure nozzle you can find. The automatic car washes claim to be no problem, but several times over the years, including my current wife, folks have mentioned that they have discovered that the vehicle came out scratched, supposedly the vehicle before them had tons of sand, mud, dirt, that stayed on the brushes, or some story like that.

I bought a Monte SS once that the owner was anal about cleaning. He regularly cleaned his aluminum original SS wheels with one of those phosphate based spray cleaners that "brighten" the wheels. I suppose it did what it said on the label, but as he continued to spray that stuff on once a week, and apparently didn't rinse it off, or adequately, it stayed seeped in around the lug nuts, and the back and center hole and started a major corrosion process. We had to destroy the wheel and lugs to get it all apart. Suggestion here is to either not use that, or rinse it well or take your wheels off and use some lubricants, etc, etc.

Nice looking truck, always loved those colors. You down along SC/GA? Savannah, Outer Banks, are old stomping grounds for me.
Yeah that sound about right, I’ll just start hosing it down more, but I’m out in Carolina beach NC.
 
1 - 2 of 2 Posts
Top