S-10 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter · #1 ·
I was hooking up my LED light bar today. I decided to hard wire it, especially since my truck had a 6 pin plug on it. I used a voltmeter through the 6 pin plug to designate the individual wires. I labeled the wires, then hooked them up to the light bar. When i put the left turn signal on, the right light bar turn signal comes on. When I put the right turn signal on, i expected it to be the opposite, but instead the right turn signal still came on. When the caution lights are on, the whole thing lights up. I have no idea what the problem is. So i take the wires all off and test them with signals on. When the right turn signal is on, the wire i designated right turn signal shows a postivive pulsing current. When i do it for the left turn signal, the wire i designated left turn signal shows a positive pulsing current. The problem is, when i put the caution lights on, You would expect the right and left turn signal wires to show current, but instead, the left turn signal wire and the brake light wire, show current. Even crazier, is that when the brakes are held down, the left tun signal wire, the brake light wire, and a random little wire under the truck shows continuous current.
 

·
Registered
Joined
·
236 Posts
Discussion Starter · #2 ·
Well, I got everything working except for one question. Are LED light bars supposed to act as a running light to? It comes on when i put my headlights on, but im not sure if it gets brighter when i put my brakes on. Then again, its daytime so i guess ill have to find out tonight. For those who wonna know the wire colors.
Left turn signal= Yellow
Right turn signal= Light green
Reverse= Lime green
running lights= black (It looks black)
Ground= 16ga white (the smaller of the two white wires)
 
1 - 2 of 2 Posts
Top