S-10 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter · #1 · (Edited)
Is this hard to do ?I have a 96 S10 4.3L auto vin X
I dont wanna pay $120 labor to have them changed when they cost as much as they do and i have to buy 3 of them.
What part of the truck are they all on? I know one is past the cat but what about the others?
Can someone walk me through this?
Anybody?

THANKS!
 

·
Insane Network Engineer
Joined
·
5,969 Posts
should be 4 of them, on on each header, one just before and one after the cat.... Just use the proper sized open mouth and mebbe tap on the wrench with a hammer to loosen it up... Depending on how your exaust system looks, you might need a little penetrating oil
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #3 · (Edited)
So they are easy to reach and remove for the most part?
Anything i need to do after the install? Like take the negative off my battery or anything?
THANKS
 

·
Early Member
Joined
·
3,278 Posts
You would only need to disconnect the battery after the install, if there were trouble codes indicating your O2 sensors were faulty.
 

·
Project: Sabriel
Joined
·
12,550 Posts
there's 3, i believe. ome somewhere on the manifolds/y-pipe (never looked for it), one before the cat, and one after. there's also no reason to replace then unless they're throwing a code or the engine is running lean/rich.
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #9 · (Edited)
Yeah the cat has been checked and is fine...

"If you want better gas mileage do a tune-up and regularly check your tire air pressure."

That i already have done and do do so this is just another oem replacment that may help out in mpg area
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top