S-10 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
431 Posts
Discussion Starter #1
The problem is is dosent work anymore lol, i have a 97s10 and the gas gage is stuck on full, the only time it moves is when i turn the key and start the engine it will move to half then go right back to full no i dont know if thats electrical or could it be the float in the tank? any one else ever had this problem or heard or this happining? thanks

lata kev
 

·
Resident Mechanic
Joined
·
365 Posts
i have that problem with my truck sometimes, my floats sticks i have heard of other s10s havin the same problem i just lock up the brakes after i fill up and that usually brings it back down
 

·
Registered
Joined
·
431 Posts
Discussion Starter #3
i know that other s10s have had that problem before but i dont think that lockin the brakes up is gonna help the gage has been like that for a while and besides i think that would just be to easy LOL i think its a sensor in the tank that will probelily cost a ton to fix w/ my luck
 

·
Resident Mechanic
Joined
·
365 Posts
mine got stuck for like 3 weeks after the frist day i got the truck this has happen in other chevy products i know this bcuz i wokr on cars ALOT but anyways usually the float gets hung in the gas tank if u could swurve or sling a doughnut or jam the brakes it will usually sloss the gas around and knock it down make take 2 or 3 tries but works for me everytime :D better than pullin the gas tank and replacin the entire thing when u know a few months down the road it will be doing the sh1t again... hehe and at leaste GM products have small probs like this if it was ford havin the problem the gas tank would have feel off along with the rear-end, bumper, shocks, and more than licky the drive shaft.... GM and dodge dont have that many problems though, only thing dodge has trouble with is their transmissions fallin off and hehe chevys rapin them
:thumbup:
 

·
Registered
Joined
·
1 Posts
I had the same problem with my 97. I had about 2500 miles on it when it stuck I took it back to the dealership and they told me it was a loose ground wire. Problem solve until around 187,000 miles when it stuck again, guess what it was the ground wire for some reason it works it's way loose.
 

·
Resident Mechanic
Joined
·
365 Posts
That is tru too, since our fuel pumps ground and pos wire are only slid onto the connectors on the pump in the gas tank i am sure the wire could be moved off easily......we were puttin anew fuel pump in one a few months ago and everytime we would go to lift the tank and slide the pump in the wires would pop off:mad:
 

·
Registered
Joined
·
431 Posts
Discussion Starter #7
i never thought of that it the ground something easy to get to or am i looking at a long hard project ( you can see im not really fimular w/ these things ) lol
 

·
drag~N~spark
Joined
·
9,530 Posts
i have a 95' just took the bed off like last sat. to wash the underside, lol i was board.:drinkhaha anyways, the ground wire is really easy to get to even if you still have the bed on, get up underneith, and where you see the neck filler, follow it down and you will see it grounded to the frame rail, black wire. on my i had to relocate it to the outside bolt that holds the front leaf hanger, either way its very easy to mess with. any q's man gimmie e-mail at [email protected]


peace steve :thumbup:
 

·
Registered
Joined
·
40 Posts
same problem here, i heard it was the fuel level sensor sender or something, $100, dont let the dealership jockeys tell you its the $470 pump
 

·
Registered
Joined
·
280 Posts
i fixed mine by clutching and braking to get the gas to slosh and it fixed it.

but i might have to check on the escort cause its stuck on full maybe the cround is bad.

anyone know and easy way to check the ground on that sending unit.
 

·
Registered
Joined
·
431 Posts
Discussion Starter #11
well the gage has been stuck on full for a while now i been woeking on my xtreme. But now i kinda wanna fix this, i have tried driving fast and speeding up around corners and i appreachate you guys help hopefully i can find it now thanks

lata kevin
 

·
Registered
Joined
·
40 Posts
xtreme11678 said:
well the gage has been stuck on full for a while now i been woeking on my xtreme. But now i kinda wanna fix this, i have tried driving fast and speeding up around corners and i appreachate you guys help hopefully i can find it now thanks

lata kevin
not sure if that would help, i have taken mine off roading and it wouldnt come unstuck from that
 

·
Registered
Joined
·
431 Posts
Discussion Starter #13
You know the one thing that really pisses me off about chevy is one other person on here said that they had problems that year w/ gas gages and also i don't know about any of you other guys out there w/ 97s but ive also had to replace my cluch fan 6 times already and the dealer said they had problems that year w/ those to so i ask WHY DOSENT CHEVY RECALL THESE TRUCK FOR THESE PROBLEMS LOL oviesly im not the only one here w/ this problem lol

lata Kev.
 

·
Resident Mechanic
Joined
·
365 Posts
Y not just get a E-fan? cheaper to replace ur clutch fan, runs the engine cooler, and uh frees up a little HP :D
 

·
Registered
Joined
·
431 Posts
Discussion Starter #15
well the reason i havent done that is because this truck is just gonna be like my winter truck im gonna be dumping money into my other truck, witch is my 00 xtreme. i dont have the money to do mods to both. and out of those 6 cluch fans i have only had to pay for 1 the rest were warinted.

lata Kev.
 

·
Registered
Joined
·
431 Posts
Discussion Starter #17
well ill tell you a month ago the timing chain went so i spent 600.00 fixing that and the valves and seals to i think if i had to pay for all those fans i would have drove the dam thing off the peir at the end of my street. LOL

lata, kev
 
1 - 17 of 17 Posts
Top