S-10 Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
1,160 Posts
Discussion Starter · #1 ·
How many miles you guys/girls getting on fuel pumps?
I got 180,000 and I am 99% sure mine is shot now.....turned the key the other day heard weak sounding pump..fired for a second or two then didnt hear pump anymore....checked it the next day, its started up and was fine...today went to the garage, no pump sound, wont fire. Bought a new pump, bout to install it.
 

·
terrible. take a lap.
Joined
·
4,024 Posts
wouldn't be surprised if it were toast but you could always switch the FP relay under the hood with another and see if that does the trick?

nice ride btw, i like it
 

·
Registered
Joined
·
183 Posts
i am having trouble with my pump too !! I was wondering what pump ya got to replace because I hear aftermarket pumps are no good
 

·
terrible. take a lap.
Joined
·
4,024 Posts
no, stock replacements are no good.

walbro 255 from summit
 

·
Registered
Joined
·
97 Posts
That's weird, my pump went out this morning after filling tank and wouldn't start when I went to leave. Advanced had a pump and I had it towed away and I pulled the bed all the way off. Ring around pump was to rusty to get off without breaking and it's a dealer only part. Not to mention im four hours from home and did all that in the parking lot of a mechanic which was closed casue it's Sunday. Truck 124,000mi on it btw.
 

·
Registered
Joined
·
183 Posts
tis the season for fuel pumps !!! check out my puzzled thread for the out come not good
 

·
Registered
Joined
·
97 Posts
Yea didn't know it was related ha but I read it. My lucky you, I'm sitting at a super 8hotel in Marietta Ohio. Moving to north Carolina but damn Junk s10s are cursed for me. Hoping tomorrow theycan have it fix before checkout. I used the airtex pump as well but you seemed like it was a bad thing, the other guy posted and said USE aftermarket pumps I thought.
 

·
Registered
Joined
·
183 Posts
Well idk seems like stock replacements are no good and dont really last too long, I was told the stock replacements dont have enough pressure for the vortec motors ?!?
 

·
Registered
Joined
·
97 Posts
So let's clear this up...if it's not OEM then it's aftermarket...but your saying the airtexpump is a stock replacement which makes that what? Aftermarket or OEM.
 

·
terrible. take a lap.
Joined
·
4,024 Posts
oem replacement, airtex is one i haven't heard good things about. You could be replacing your fuel pump in another year.
 

·
Registered
Joined
·
97 Posts
He charged the battery and it started right up this morning! Not sure wether to have him change it or get my 273bucks back
 

·
Registered
Joined
·
59 Posts
my fuel pump was failing on and off. Didn't think it was the pump at first... I'm in ohio and it's getting cold. If you spent the money already, change it out LoL
 

·
1996 4.3 5 speed xtra cab
Joined
·
485 Posts
Bought my truck in July. Replaced it for the hell of it. It looked like it was replaced already by an aftermarket one with the whole assembly. Threw in the stock Turbo Buick Walbro pump for the hell of it. No problems. Sounds funny with teh door buzzer and the pump noise when you have it running.:rolleyes:
 

·
Registered
Joined
·
588 Posts
I had the OEM fuel pump fail completely right after I drove it to the shop to replace brake lines and the fuel pump since they were already dropping the gas tank. First time I allowed it to run to just below 1/4 tank and the pump failed because of it. I had it replaced with a Walbro TU429 from fuel-pumps.net. $138 for the special order item + overnight shipping AFTER they get the special order pump. The noise that the pump makes always varies. It gets noisier when the tank gets to 1/2 tank or sooner than that. However, it is not as loud as the OEM pump was. The prime cycle noise sometimes bothers me since it sounds like it is "barking" if I am parked on a concrete floor. Other times, it sounds okay. Sometimes it quiets a bit if I use Lucas. I really do hope that getting this pump was not a mistake. I had it installed at 93,000 and I have 97,500 on it now.
 

·
1996 4.3 5 speed xtra cab
Joined
·
485 Posts
I had the OEM fuel pump fail completely right after I drove it to the shop to replace brake lines and the fuel pump since they were already dropping the gas tank. First time I allowed it to run to just below 1/4 tank and the pump failed because of it. I had it replaced with a Walbro TU429 from fuel-pumps.net. $138 for the special order item + overnight shipping AFTER they get the special order pump. The noise that the pump makes always varies. It gets noisier when the tank gets to 1/2 tank or sooner than that. However, it is not as loud as the OEM pump was. The prime cycle noise sometimes bothers me since it sounds like it is "barking" if I am parked on a concrete floor. Other times, it sounds okay. Sometimes it quiets a bit if I use Lucas. I really do hope that getting this pump was not a mistake. I had it installed at 93,000 and I have 97,500 on it now.
Look at the bright side...youll know it when the pump goes bad and not working...:)
 

·
Registered
Joined
·
588 Posts
Look at the bright side...youll know it when the pump goes bad and not working...:)
I agree, but I would prefer to never have to use my AAA card again. I keep my truck maintained the best I can to prevent any of that. If there is anything wrong with the pump, I would get it replaced BEFORE it fails so it doesn't get to that point. THAT was a hassle last time I used it when I lost brakes on the Garden State Parkway in NJ. I have AAA Plus now, but I would like it to keep collecting dust until this truck completely rusts out in another 10 years (which won't even happen then because I neutralized what little rust was on the frame with rust converter and covered it in undercoating. I also get on my knees and wash the undercarriage when I wash the truck to prevent the NY mud and salt from getting to the metal.).
 

·
Registered
Joined
·
97 Posts
they only charged me $87 though i had to take the bed off and put it back on in his parking lot. cant wait for the next thing to go bad.
 

·
............
Joined
·
833 Posts
That's weird, my pump went out this morning after filling tank and wouldn't start when I went to leave. Advanced had a pump and I had it towed away and I pulled the bed all the way off. Ring around pump was to rusty to get off without breaking and it's a dealer only part. Not to mention im four hours from home and did all that in the parking lot of a mechanic which was closed casue it's Sunday. Truck 124,000mi on it btw.
I got one from rockauto.com. Think I've seen them on ebay as well.


You can take the "module" apart and stick in a pump from a CPI truck unless you have the robust fuel crap.
 
1 - 20 of 29 Posts
Top