S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi sorry if this is wrong spot but im stuck I have an 87 s15 and the governor on the 700r4 locked up the truck wouldn't shift. I had a trans from an 85 s10 same motor and I put that governor in the truck shifts at super high rpm and doesn't like to shift at part throttle. Is there anyway I could have messed up installing the new part thanks
 

·
Been there Done it
Joined
·
7,077 Posts
Sounds like the "new" governor is sticking. Did you check the function of the internal valve before installing it?
Here's a video how to that shows the valve function clearly. (It helps to go to fullscreen view to see the detail inside the governor shaft) :

Normally I wouldn't recommend anything even remotely connected to monster transmissions We all know how bad a scam that outfit is, but the only other video I could find was terribly dark and you couldn't see any details. Or I wouldn't have used a monstrosity transjunk video.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thank you I did check the valve but I don't know if it opened all the way I will re check tomorrow thank you
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Is there a difference in governor between years 85 and 87 they look identical but the 87 one had a j on it the older one had a c
 

·
Been there Done it
Joined
·
7,077 Posts
Not by year, but V8, V6 and 4cyl are different. Those letters do indicate which springs are in the governor. If you can get your old one apart switch the springs and inner weights.
 
1 - 8 of 8 Posts
Top