S-10 Forum banner

1 - 20 of 22 Posts

·
Work in Progress
Joined
·
50 Posts
Discussion Starter #1
Ok, I have a 98 S10 extended cab with about 50,000 miles on it. Here in the last few days I have noticed that when I accelerate quickly usually in like 2-3-4 gear. (5 speed) It will stutter, it only seems to happen when I hit the gas hard. If i'm just driving normally in traffic it seems to do fine, anyone have any ideas what may cause this?

Thanx
 

·
Registered
Joined
·
63 Posts
Try changeing the fule filter.
 

·
Work in Progress
Joined
·
50 Posts
Discussion Starter #3
I changed it probably 9 months ago, think that could still be the problem?
 

·
Registered
Joined
·
63 Posts
I'd try that first. Its only a 11 dollor fix verse cleaning your injectors.
 

·
Work in Progress
Joined
·
50 Posts
Discussion Starter #5
anyone have any other ideas?
 

·
Registered
Joined
·
21 Posts
I will strongly agree on the fuel filter. But think hard about your last "tune-up". Going to old gas stations that may have old undergroung tanks that may be filled with moisture,water and even MUD can destroy your fuel injector. I used to work for a gas station as a teen and my boss "DRILLED ME" every day on how many old gas stations were keeping mechanics in business with dirty gas. It sound to me as a dirty fuel injector(easy to fix!) or fuel filter. Replacing fuel filter and a tune-up should do the trick.:thumbup: :
 

·
Work in Progress
Joined
·
50 Posts
Discussion Starter #7
yeah, i was also thinking fuel injector. I bought some of that fuel injector cleaner the other day, and filled up with amoco premium, i'll run that full tank through and see how it is... seems to maybe be getting a little better.

thanx
 

·
Registered
Joined
·
21 Posts
Now that I think about it!...I remember having a 4 cylinder Cavalier (that I rode to the ground) and I took it for a tune up for similar problems and the mechanic told me that the fuel injection was fine and he changed the spark plug AND wires and the car ran like brand new (0 to 60 in about one minute :rolleyes: )
 

·
Work in Progress
Joined
·
50 Posts
Discussion Starter #9
LOL, one minute.... yeah, anyone think 52k is too early for new spark plugs though? seems kinda early to me, but if they need it they need it, huh.
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
Yeah spark plugs, check the plug wires too(!!!!!!) big problem with 2.2's......

I changed my plugs at like 30,000 and plan on doing it prolly every 30,000 just to keep up with it......

check your tranny fluid, fuel filter, air filter could be a small part.....lots of stuff, but I'd definitely say check the plug wires, cause mine stuttered and sputtered and it was my plug wires

Caleb
 

·
Registered
Joined
·
132 Posts
check dis cap and rotor i had cracked dis cap and my truck putted and neer went above 25 and never could punch gas
 

·
XA FOUNDER!
Joined
·
40 Posts
easy fix for a few extra bucks...

you can always just throw an msd ignition in it and up the electricity flow to it. it claims to pick up the lag between gears and all that good stuff. I'm going to buy one for my pickup. I'll tell you how it goes.
J
 

·
The Sex Toy
Joined
·
846 Posts
im on the same boat, let me know how you did.
 

·
Registered Stepsider!!!!!
Joined
·
569 Posts
mmhyson said:
check dis cap and rotor i had cracked dis cap and my truck putted and neer went above 25 and never could punch gas
Sorry no distributor or rotor on these little Babies, Direct Ignition System (DIS)

But Check the wires, I changed mine last weekend, They looked fine, until I took off the wire clamp on top of the valve cover, there were holes in the wires underneath the plastic clamp,
Check the coil packs also, My Number #4 Contact was rusted, its closest to the ground so I'm sure water and all sorts of crap gets up in there.
Oh well, changed the coil packs(new Accel Coil packs) Wires (Accel 8MM) and plugs (good ole OEM AC Delco Platniums) Truck runs really good now.
L8R hope that helps a little bit for you.
 

·
The Sex Toy
Joined
·
846 Posts
How do you change the coil packs?
 

·
GM Trained Cadillac Tech.
Joined
·
99 Posts
To change the coil pacs. take the passenger side tire off and go in through the wheel well..and i think they are 1/4 bolts that hold them on. and the just slod on and off of the terminals. And whatever you do. DO NOT USE BOSCH PLATINUMS or you will be right back to where you started. Use OEM Delco Platinums. I Plan on replaced my Plug Wires and getting the accel high out coils.
 

·
Registered Stepsider!!!!!
Joined
·
569 Posts
yeah what he said
 

·
The Sex Toy
Joined
·
846 Posts
sweet sounds good, how much do coils go for anyways?
 

·
Registered
Joined
·
355 Posts
if you dont mind being cramped for a few you dont have to remove the tire you can sqeeze your hands in from up top and from underneath just fine. just mark with tape each wire and unplug them, and the pack are held on by 2x bolts each i think they are 9mm long. and they unplug. you can score some accel ones i think at any local auto store, but im saving for the MSD coil packs and ignition box.

http://store.summitracing.com/partdetail.asp?part=MSD-8224&view=2047
 

·
Registered Stepsider!!!!!
Joined
·
569 Posts
The accel Coil packs go for $37 at truckperformance.com
 
1 - 20 of 22 Posts
Top