S-10 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1 (Edited)
Hello everyone,

I am trying to get the starter out of a 1992 Sonoma 4x4, 5-speed with the 4.3L TBI.

I have removed it from the hole in the engine, undone both the bolts holding it in, and taken the power and ground leads off.

It is *so* close to coming out, but it is stuck - I have tried jacking up the side of the tranny (the pictures are before I tried this), and I can get it just about out, but the solenoid catches, and I just can't get it out - PLEASE HELP !!!

Here is a picture of where the starter is sitting now:



 

·
Registered
Joined
·
12 Posts
i cant really see the picture too well. but when i replaced mine i had to remove the slave cylinder. its two bolts holding it in.
i dont have a 4 wd but it is a 4.3 5 speed (92) . try it out.

hope this helps
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
By slave cylinder, do you mean the solenoid? (ie small cylinder on top of the starter) ?

Thanks!
 

·
Registered
Joined
·
12 Posts
no, you did say you had a manual tranny right?

well the slave cylinder is bolted to the tranny towards the bottom of it. its not hard to remove . its just two bolts and a hard hyd. line. leave the hyd. line connected and just swing the unit away.
just make sure the push rod is back in line when you reinstall it. or you will have trouble with shifting. seeings how that is what operates the clutch.

now that im thinking about it. if your clutch is not a hydraulic one than you might not have a slave cylinder.
if that is the case than i dont know what to tell you.
 
1 - 5 of 5 Posts
Top