S-10 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
'95 heating problem

The heat in my 1995 S-10 just went out. The fan still blows air out, but it is not warm. I think it might have something to do with the heater core, but I have no clue as to how to fix anything with the heating A/C system.

Seeing as how I go to school in the UP, this is something I need to fix yesterday.

Any help or suggestions appreciated.

Thanks.
 

·
Early Member
Joined
·
3,135 Posts
Sounds like your heater core is bad.
If you want to replace it yourself, get a repair manual, the manual will explain how to remove it.
 

·
She's in need!
Joined
·
24 Posts
I have a 95 s-10 extended cab 4.3L and mine went out about a month ago. I just went to autozone and got a new one. It sucks that you have to take the whole dash apart. I had to have a buddy help me with it just to remove the dash from the cab. It was a b****. The process took me like 4hrs but I was in no rush. Now it blows hot and strong.
 

·
She's in need!
Joined
·
24 Posts
I have a 95 s-10 extended cab 4.3L and mine went out about a month ago. I noticed that the passenger side floor underneath the heater core was wet and that was my first clue. Then it started getting cold and I had no heat. I just went to autozone and got a new one. It sucks that you have to take the whole dash apart. I had to have a buddy help me with it just to remove the dash from the cab. It was a b****. The process took me like 4hrs but I was in no rush. Now it blows hot and strong.
 
1 - 6 of 6 Posts
Top