S-10 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,288 Posts
Discussion Starter #1
Does anyone have a copy of the wiring diagram for the 98+ s10/blazers? I have a 2001 blazerX and the right highbeam does not work and it is not the bulb. So I need the diagram to search this little bugger out.
 

·
Registered
Joined
·
227 Posts
My truck has the same problem...one side does not work with high beam and i replaced the bulb...i had a shop check it out a year ago and they told me it was a $300 job to fix it i said f that..but when redoing some other elctrical work they left a wiring digram in there and i snatched up that b**** so when i get home ill check it out and put it up if its for the head lights
 

·
Registered
Joined
·
227 Posts
Sorry I can't help you out with your problem, but I have a 99 s10 and want to disable the "auto-on" for the headlights. 98% of the time my headlights are on. Having the headlights in the "off" position has no effect. What can I do?
look in the how to section and read about the drl and ahl...it tells you what wires to mess with
 

·
HEY WAS UP S-DIMERS
Joined
·
8 Posts
HI IM REALLY TRYING TO FIND THE HARNESS THAT HASS THE LOWS AND HIGHS FOG LIGHTS AND THE EXTRA LIGHTS THAT ARE ON THE TURN SIGNAL LIGHTS UNDER THE MAIN HEADLAMPS I HAVE SEEN EXTREMES AND BLAZER WITH THESE LIGHTS BUT I CANT FIND THE HARNESS TO DO IT ON MINE
 

·
HEY WAS UP S-DIMERS
Joined
·
8 Posts
Hi Im Really Trying To Find The Harness That Hass The Lows And Highs Fog Lights And The Extra Lights That Are On The Turn Signal Lights Under The Main Headlamps I Have Seen Extremes And Blazer With These Lights But I Cant Find The Harness To Do It On Mine
 

·
2000 GMC Typhoon?
Joined
·
62 Posts
My lights were Not working, and my jimmy would shut off on its own right after the highbeam Indicator light would come on. cause i had HIDs in my HighBeams.
First the DRLs Would flicker for about a week, then the second week they would turn on, now it just shuts off the whole car.

Problem was it melted the inside of the fuse box under the hood and shorted out the whole suv.

Now I gotta get a whole new Box.

this time i'm gonna run relays for all my lights, HEAD/HIGH/FOG.
acctualy i was gonna put the stock highbeams in the bumper, and run HIDs in the Highbeam compartment, straight from the battery to a relay to a switch.
 

·
Registered
Joined
·
3 Posts
2003 Chevy s-10 turning signal problem

Guys I have read every post on the internet about s-10 turning signal problems and I have a unique one...

On my dash board it says my left turning signal is out. I turn on my hazards (which are all the same lights as my running lights, and turning signals) They all work. I turn on my headlights and the front left running light is out and also the front left turning signal. However! when I engage the left turning signal they work but flash really quick like one of the lights are out. When I lock my truck with the standard alarm the front left lights also don't flash. Only the right ones. after having a coke and watching my hazards flash I noticed the front left running light (bottom light) only has one filament lighting up. I swapped the bulbs and same. result. What on earth is causing this. I also clipped my hitch connector with no fix. (stupid me).. Please HELP!
 

·
Registered
Joined
·
1 Posts
Hey Josh, could be a ground problem have you probed the ground wire for the left turn? On my blazer that connector has 3 wires, brown/parking, black/ground and green/signal/flasher. You can unplug the connector and try to probe; red probe to battery and black probe to the connector w/black wire volt meter on dc you should get 12-14 volts.
Or you could just make sure and tie in your own ground from one of the body screws to the black wire close to the connector with one of those squeeze quick connectors.
 

·
Early Member
Joined
·
3,114 Posts
Talk about reviving a old thread!
 

·
Registered
Joined
·
2 Posts
Sorry I can't help you out with your problem, but I have a 99 s10 and want to disable the "auto-on" for the headlights. 98% of the time my headlights are on. Having the headlights in the "off" position has no effect. What can I do?
click the dome over ride in and out four times, should disable the auto on but only until you shut the vehicle off and turn it back on.
 
1 - 16 of 16 Posts
Top