S-10 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
well my gas guage dont work,
it was sitting for 3 years after not being able to afford to fix it
finaly can and gas guage dont work well sorta says there is 1/8th tank after i put 30 bucks in(1.15 for premeum)
butt question is could it be the float or do they have floats or any other ideas?
 

·
peace and big boobs to u
Joined
·
6,026 Posts
they sell the tank sender assembly for around $120 at lmc also check your local parts store sometimes they are cheaper. its probably not the float but more a sticky lever
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
Ok, man these new members are getting hard to follow....anyway, you did change the pump or your going to change the pump? If you changed the pump then you know it has a float, if so and now it does not work did you bend the arm? Did you break a wire off? Etc. etc....
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
it says need advice before taring apart. i have not takin the pump out. nor looked at it. the gas guage says it has 1/8th of tank no matter how much gas i put in. i have not broke anything. i got the truck 4 years ago and just finaly got runing it has 3/4 tank full of gas when i got it and it sat like that for 3 years. this year i finaly had money to put into it. i drained the tank and filled with new gas but the guage didnt move till i filled it right to top.
and when i filled it to the max it would let me the guage went to 1/8th of a tank. it will move about half a inch either way but thats it.
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
Check the gauge sender with an Ohm meter at the back of the cluster or at the pump. Give me a year and motor and I will pull up a diagram.
Sorry guy, your just hard to follow, ya it says advice before tearing it apart, but then you say it sat for 3 years because you could not afford to fix it, fix what? You say the gauge worked before......I guess?
 

·
ASE certified MasterTech
Joined
·
8,695 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #8 ·
sorry sometimes i cant word my word the way they should but its a 87 2.5L
and k ya the truck sat 3 years casue i could afford to put any money into and that that i can it needs bunch stuff, and i couldnt afford to fix anything lol
and about the 18th tank k truck sittin i drained tank added ten bucks tank said 3/4s full i got insurence and went to the store and filled the tank but when i filled the tank the guage went to 8th of a tank is wat i ment
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #9 ·
and money into it* and now that i can put money to it needs bunch stuff*
and now no matter how much i put in it barley moves my first thought was the float got stuck from sitting for so long and now just wont move.?
 

·
peace and big boobs to u
Joined
·
6,026 Posts
when i put my truck into storage it had a full tank of gas plus a bottle of fuel stabilizer, and was running fine. 3 years later i took it out of storage and i had to replace the fuel pump, fuel filter, and injector pod to get it running again and there was not a drop of fuel in the truck. at first the fuel gauge would show half a tank and be out of fuel and would go to full when full, it would only move during the last 5 gallons of fuel. i should have replaced the fuel sender but i didn't have the money at the time, i have left it in there for over 5 years and it shows full when i fill it up and it gets down to under a 1/8th of a tank when it runs dry(i just use the odometer for a fuel gauge).

so you can do it many different ways
 
1 - 13 of 13 Posts
Top