S-10 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1994 Sonoma 4.3 tbi z series, I'm looking for fuel pump relay.i replaced coil,sensors,and about anything else. Ran fine,got back home wont start. Fuel pump wont kick on.Can someone point me to it please.Thanks I spent alot of money already.
 

·
B4U Task Force Admin
Joined
·
25,337 Posts
Moved to 262/4.3
 

·
Registered
Joined
·
93 Posts
It's quite probable that under the hood there's a "fuse box" , it'll have relays in it & on the inside of the cover they will be listed , also there's a strong probability the fuel pump relay will have the same no's on top as another , so if you switch them out , you'll know if that's the problem ?
 

·
Been there Done it
Joined
·
8,997 Posts
Underhood fuses boxes (UBEC) started in 98. On the 94 pickup it is in the "convenience center" inconveniently located below the dash under the center of the dash. You have to remove the lower under dash trim panel to "conveniently" get to it.
You can swap it with one of the other relays to test your theory. Just be sure the other one has the same number of pins.

336236
 
  • Like
Reactions: Frank Bukowski

·
Engineer, Member SAE
Joined
·
54 Posts
First suspect is the FUEL PUMP. Theyll do that...just up and quit, in the middle of an intersection. It happened to me.

I realize its not working right now, but when standing beside the driver door where its quiet, it should be no trouble hearing it running. Realize at key-on, itll just run briefly to pressurize the system then shut off.

Put a voltmeter on the fuel pump wire and check for voltage. After guessing at the relay, theres not much more guessing that works- time for troubleshooting.
 
1 - 5 of 5 Posts
Top