S-10 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
99 2.2 stick, 193K miles. It's always been hard starting....it'll crank for a full 2-3 seconds before starting. It's done that for the 50k miles I've owned it. Plugs, wires are fresh. Lately, it's been lugging BAD while driving and accelerating. It'll intermittently fall on it's face.

It only has about 37-40psi while starting and running, and I know it should be around 60. Any ideas on it being either the fuel pump, and/or fuel pressure regulator? I had a 97 V6 s10, and did the pump on that. I know the V6 fuel pumps are known for going. Is it the same pump for the 4s? Are they known for going also, or should I do the regulator instead, or just both?
 

·
time to get cereal
Joined
·
3,562 Posts
Did you check for leaks? You might have leaky injector(s).
 

·
time to get cereal
Joined
·
3,562 Posts
If one or more cylinders were flooding? I would think so.

You could always check for a plugged cat too.
 

·
It's mostly BS
Joined
·
2,799 Posts
The fuel pressure spec for that model is 41-47 psi.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #6
My friend looked up the fuel pressure 2 days ago and it said it should be closer to 60?
Yesterday on the way home it nearly died on me. Giving it gas, it sputtered and would barely move. It would then shudder and buck. Wouldn't go more than 25mph or so. Finally pulled over and stalled. Cranked over, and suddenly it drove fine again. But when pulling home, I could tell it was off, it did fell like it wasn't getting gas.
I parked it and just ordered a fuel pump from rock. That'll be my first attempt at fixing this. Then FPR.
 

·
It's mostly BS
Joined
·
2,799 Posts
There's a ground lug on the frame back by the rear bumper on the driver's side that will crud up and cause all sorts of problems. Might want to make sure that lug is clean and tight.

BTW, the flex fuel vehicles are the ones that get the 60 psi pump.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #8
So 35-40 is normal? I already ordered the pump.....is it worth changing
 

·
94 4x4,01 Blazer
2001 Blazer 4dr 4wd LT
Joined
·
1,185 Posts
does it do it stone cold? and have ever looked underneath after a stall out- could be a cat meltdown.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #11
It's completely erratic. It tends to do it after driving maybe a good 10min so or. It'll do it either under acceleration or cruising, air on or off. 2 weeks ago it almost died, couldn't go faster than about 20. It stalled, restarted, then after normally the final 5min home. But I knew it wasn't fixed. No codes ever popped. Did the pump, regulator, and relay, and still not fixed.
 
1 - 11 of 11 Posts
Top