S-10 Forum banner

Status
Not open for further replies.
201 - 220 of 226 Posts

·
lq4 s10
Joined
·
662 Posts
Looks great! Im so excited for you. I would have a hard time not driving it everywhere and at the same time kicking myself for driving everywhere.
 

·
Registered
Joined
·
1 Posts
I have a 86 s15. With a 2" drop in the front 3" in the back. Can I run the LS3 or H3 oil pan without having to notch the crossmember ?
 

·
Registered
Joined
·
4 Posts
Hey railn20s. Quite an impressive build you have there!! I plan on swapping the 5.3 in my 1st gen here soon and have always wondered about the a/c. What all is involved in getting the a/c to work with all that motor in there??
 

·
Rolnlow
Joined
·
790 Posts
Discussion Starter #213
There are a couple other for the A/C compressor. I Chose to run the low mount a/c so I notched the frame to make room. I plan on finally getting it hooked up this winter. I finally have all the part needed except getting the new hoses made
 

·
Registered
Joined
·
2 Posts
just now read this build and i am starting a lq4 swap into my 88 s10 was just wondering what all went into the wiring side of things did you use the computer and harness out of the car you pulled the 5.3 and get the computer reprogrammed?
 

·
Rolnlow
Joined
·
790 Posts
Discussion Starter #218
Yeah I used the factory 5.3 harness and computer, you will need to use some of the stock s10 harness also.
I used this place for my computer reflash and he has tons of good wiring harness infor on his website, he used to do LT1 stuff so the website is still LT1 but most of the stuff is LS swap stuff now. Guy is super nice and helpful
http://lt1swap.com/wiringharness.htm
 

·
Registered
Joined
·
65 Posts
I understand that this is an old thread. I got some questions if you could be able to help me out. I am still working on my 1986 GMC S15.. LS swap. was a 4 speed manual but putting a 4l60 in it with lokar shifter.. But if you could I would love to talk about your truck.
 

·
Registered
Joined
·
65 Posts
I was just going to update my last post but do not know how or it wont let me. I have read every page of this and love it. been looking for information like this for a long time! I really appreciate you taking the time to post this and with all the pictures it helps a lot.

I understand you used the 98-99 F-Body manifolds? just cut off the flanges and welded extensions on then ran the exhaust? did I read that right?
You used a all aluminum radiator. after your first one was broken. What was the first radiator? PN#? I'm guessing a 4.3L radiator for a old square body? I found a all aluminum rad on the site you recommended but said out of stock and awaiting a reply on if they will get more. Thanks for that. but how did you run the steam port?
Do you have any pictures of the wiring? I am at that stage. But I got the standard No Gauge cluster just dummy lights. with aftermarket gauges under dash.
What PN ACDelco pump did you use? modifications? lines? I got a million and one questions if yu might be able to help or of anyone can help.

Please message me and we might be able to email.

By the way, Mine is a 1986 GMC S15, Base, STD cab short bed, Manual brakes, Manual Steering, Just a base truck not looking for a hotrod just a fun daily.
 
201 - 220 of 226 Posts
Status
Not open for further replies.
Top