S-10 Forum banner

1 - 20 of 28 Posts

·
I'm bagged bitch!
Joined
·
154 Posts
Discussion Starter #1
hey everyone .. well i finally got the front of my Xtreme bagged! with the help of George - 99Xtreme ... it gets pretty good lift and i'm about an inch off the ground up front cuz the tires are sitting on the fenderwells ... so i take it for a test drive around the block and there's this really loud chattering noise at full turn .. the toe looks like its rubbin against the inside of the tire ... i'm takin it for an alignment tomorrow .. i hope that will fix the noise ???

pics are on their way .. as soon as i get my digital camera from school! later

Chris
 

·
Xtreme Dreams..
Joined
·
1,939 Posts
I forgot to adjust your dump valves, remember the dial on the top of you valves, See if your dumps are set to Air
 

·
I'm bagged bitch!
Joined
·
154 Posts
Discussion Starter #8
UPDATED!!

Hey everyone! i've been so busy with school that i haven't had much time to fix some of the bugs. today i took care of all the leaks, but i still have to take care of the kink on the passengers side!! it takes forever to lift and drop!!

in the meantime here are some pics i took today.







 

·
Xtreme Dreams..
Joined
·
1,939 Posts
Jim & Chris, you guys gonna cut that 5/8" hole in the frame so you can run the line right in???

Chris did the alignment fix that rubbing Problem??
 

·
I'm bagged bitch!
Joined
·
154 Posts
Discussion Starter #14
Thanks guys for the comments!! :thumbup:

99xtreme said:
Jim & Chris, you guys gonna cut that 5/8" hole in the frame so you can run the line right in???

Chris did the alignment fix that rubbing Problem??

yes, we're gonna cut that 5/8" hole next to the upper shock mount and run the line in there, but we haven't done it yet !


i still haven't gotten an alignment, but the rubbing sound went away :dunno:
 

·
Xtreme Dreams..
Joined
·
1,939 Posts
1lowxtreme said:
Thanks guys for the comments!! :thumbup:




yes, we're gonna cut that 5/8" hole next to the upper shock mount and run the line in there, but we haven't done it yet !


i still haven't gotten an alignment, but the rubbing sound went away :dunno:
Free repair, maybe what ever was rubbing was rubbed down away from the tire.. Chris if you guys need a hand, let me know. I'll just make sure I don't bring the sawzall king with me...
 

·
Registered
Joined
·
878 Posts
Yeah, if you wouldn't mind...

Did you put the bags on yourself? I am ordering my front kit tomorrow and I will be doing it myself and I was wondering how hard like 1-10 (10 being the hardest) you would say it is. I have quite a bit of tech. skill but I am kinda shaky on the whole bag idea, lol.
 
1 - 20 of 28 Posts
Top