S-10 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I think that I either got a motor mount loose or the engine might be loose from the transmission.It is like the engine is tilting back during hard acceleration thus causing the fan to rub the shroud. This only started about 2 months ago. I was just wondering if anyone else had these problems oh yeah its a 99 2 door blazer 4.3L. Any help will be appreciated thanks.
 

·
Registered
Joined
·
4,257 Posts
I'd say it's most likely a motor mount gone bad.
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
broken motor mounts...

either boosted thrills or Jags that run mounts are going to be your best bet since the stock mounts SUCK
 

·
Registered
Joined
·
363 Posts
My friend had the same problem with his 79 F-150 and every time he accelerated hard or tried to powerstall the engine lifted up in the engine bay as if it was gonna jump out. He had a nut missing from one of his engine mounts. He replaced it and problem solved. It also robs you of power since the engines movin around instead of putting powerr to the ground.
 

·
Registered
Joined
·
2,371 Posts
blackout357 said:
My friend had the same problem with his 79 F-150 and every time he accelerated hard or tried to powerstall the engine lifted up in the engine bay as if it was gonna jump out. He had a nut missing from one of his engine mounts. He replaced it and problem solved. It also robs you of power since the engines movin around instead of putting powerr to the ground.
HAHA thats happening to me right now. I gotta get my mount fixed.
 

·
Registered
Joined
·
111 Posts
I got into a front end collision and the fan started hitting the fan shroud. Sure enough, it was the engine mounts.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #9 ·
Just wanted to let you guys know that i checked into it and sure enough the rubber on the drivers side engine mount had came apart. Had to get a new mount on that side. Ended up taking the inner fender off to get to the complicated thing though. It was pretty tough but that fixed it. Thanks
 
1 - 10 of 10 Posts
Top